VMware workstation 5.5 won't install on Edgy

Paul Kaplan pkaplan1 at comcast.net
Mon Dec 18 10:45:30 UTC 2006


On Monday 18 December 2006 2:25 am, Remzi AKYÜZ wrote:
> Hello,
> can you vmware-server ?
> I think vmware-server is better than vmware workstation and it is free :)
> can you look at this
> http://www.vmware.com/products/server
> page ?
>
>
>     VMware Server
>
> <http://www.vmware.com/download/server/>
> <http://www.vmware.com/download/server/>
>
>
>     Experience Server Virtualization - Free!
>
There's also vmware-player which is available as a deb package for edgy thru 
one one of the repositories, but it doesn't allow you to create new vms; you 
can only open existing ones, and you can't change the virtual hardware 
configuration once created.
Paul
>
>
>
>
> Good luck
>
> Remzi
>
> Paul Kaplan wrote:
> > On Sunday 17 December 2006 6:54 pm, Gabriel Dragffy wrote:
> >> Running the installation script for this, have linux-headers-386 and
> >> build-essential installed. Worked perfectly on Dapper but on Edgy it
> >> hits a snag. I'm hoping someone would be able to suggest what exactly I
> >> need to do to get passed it. The following is the last few lines of
> >> output as the program exited...
> >>
> >>
> >>
> >>
> >> /tmp/vmware-config1/vmmon-only/./include/compat_wait.h:37:5: warning:
> >> "VMW_HAVE_EPOLL" is not defined
> >> /tmp/vmware-config1/vmmon-only/./include/compat_wait.h:43:5: warning:
> >> "VMW_HAVE_EPOLL" is not defined
> >> In file included from /tmp/vmware-config1/vmmon-only/linux/driver.h:20,
> >>                  from /tmp/vmware-config1/vmmon-only/linux/driver.c:49:
> >> /tmp/vmware-config1/vmmon-only/./include/compat_wait.h:60: error:
> >> conflicting types for ‘poll_initwait’
> >> include/linux/poll.h:62: error: previous declaration of ‘poll_initwait’
> >> was here
> >> /tmp/vmware-config1/vmmon-only/linux/driver.c:145: warning:
> >> initialization from incompatible pointer type
> >> /tmp/vmware-config1/vmmon-only/linux/driver.c:149: warning:
> >> initialization from incompatible pointer type
> >> make[2]: *** [/tmp/vmware-config1/vmmon-only/linux/driver.o] Error 1
> >> make[1]: *** [_module_/tmp/vmware-config1/vmmon-only] Error 2
> >> make[1]: Leaving directory `/usr/src/linux-headers-2.6.17-10-generic'
> >> make: *** [vmmon.ko] Error 2
> >> make: Leaving directory `/tmp/vmware-config1/vmmon-only'
> >> Unable to build the vmmon module.
> >
> > Make sure you have the linux-source package for your kernel installed. 
> > Also run vmware-config.pl as root (sudo).
> > Paul




More information about the ubuntu-users mailing list