Correction: Re: Desktop launcher as root

Peter Garrett peter.garrett at
Sat Apr 29 23:31:10 UTC 2006

On Sun, 30 Apr 2006 09:01:16 +1000
Peter Garrett <peter.garrett at> wrote:

> On Sat, 29 Apr 2006 18:33:40 -0400
> Frank McCormick <fmccormick at> wrote:
> > 
> >    I've been trying unsucessfully to create a desktop launcher for midnight commander but as root. I've tried gksu, gksudo, sudo, su, and gksuexec. I guess the catch is mc has to be run in a terminal as root. Nothing I have tried works. Got any suggestions, I must be missing something obvious!
> Try a "normal" launcher with
> xterm -e sudo mc
> or
> gnome-terminal -e "sudo mc"

Apparently a "straight" command like this without "gksudo" only works in
gnome if you tick "Run in Terminal"

I have no idea why... apologies for the error: I tried this in Fluxbox,
not realising that this was YAGE (Yet Another Gnome Eccentricity )



"Hyperlinks subvert hierarchy."

-The Cluetrain Manifesto

More information about the ubuntu-users mailing list