Firefox on Dapper fails on https even though mozilla-psm is installed

Erik Forsberg forsberg at
Wed Apr 26 18:42:16 UTC 2006

Hash: SHA1

"Darryl Clarke" <smartssa at> writes:

>> My firefox is causing trouble. It refuses to visit https sites,
>> instead giving me this error message:
>> Unexpected response from server Firefox doesn't know how to
>> communicate with the server.
>>     *   Check to make sure your system has the Personal Security Manager
>>           installed.
>>     *   This might be due to a non-standard configuration on the
>>         server.
>> This is odd, since mozilla-psm is indeed installed:
>> I've tried purging (dpkg --purge) firefox, mozilla and mozilla-psm
>> then reinstalling. Didn't help. I've also tried removing my ~/.mozilla
>> to see if the problem was profile-related - didn't help.
>> Mozilla happily visits https sites, so the mozilla-psm library seems
>> to work at least partially.
>> Any help on this would be appreciated!
> mozilla-psm is specific to the mozilla-suite.

Yeah, you're right. I was confused. 
> If you've reinstalled FF and it's still failing, It's probably a local
> user configuration issue.
> The firefox profile is in ~/.firefox/

Well, mine is in ~/.mozilla/firefox, and if I make a new profile, it's
placed there as well. 

I think the location of firefox profiles has varied over the years,
and if you already had one in one of the possible locations, it'll
continue there.
> Before blowing away your profile though, you can create a new one to
> test by running 'firefox -ProfileManager'

Tried that, didn't help. Also tried running firefox as a different
user (root), didn't help either. Irritating. 
> HTH.

Unfortunately not, but thanks anyway! 

- -- 
Erik Forsberg       
GPG/PGP Key: 1024D/0BAC89D9
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Processed by Mailcrypt 3.5.8+ <>


More information about the ubuntu-users mailing list