strange problems with Internet connection

Keith Richie disturbed1976 at
Sun Apr 16 02:57:45 UTC 2006

I have been plagued with these same problems with Ubuntu. What I did to fix
it was set up my connection with a static IP. Depending on your router, set
your IP as something like, also set the gateway as your
router's IP. I've tried disabling IPv6 system wide, in Firefox...... none of
that solved the problem. I thought it was a flaky DNS from my ISP, so I
tried several different, no luck. Once I set a static IP everything was
solved. Upon a fresh install of Dapper plagued with the exact same network
problems. So I did the same, set up a static IP, but left IPv6 enabled, zero

I wonder exactly what the problem is though? I don't have these issues with
CentOS, nor Windows. It doesn't matter if I use a Netgear or Linksys router,
or if I connect directly to the cable modem. Unless I specify a static IP,
my connection is slow and intermittent.

Reading this list, and the forums it seems to be a common enough problem
though, that is always passed on to the fault of the router. I don't believe
this is it. If it was, people would be having the same issues inside
Windows. Windows XP and 2000 both have IPv6 enabled by default. Perhaps the
DHCP client is bugged? Who knows.

On 4/15/06, Lutzer <M.Lutzer at> wrote:
> Tod,
> Tod Merley schrieb:
> > below V
> >          V
> >
> > On 4/15/06, *Lutzer* <M.Lutzer at <mailto:M.Lutzer at>> wrote:
> >
> >     Unfortunately after some more testing I experienced the problem
> several
> >     times again. I disabled IPv6 in Firefox and systemwide (as described
> by
> >     Thilo) which did not helped to get rid of the problem. Probably IPv6
> is
> >     not the reason. Some more ideas how to fix it?
> >
> > Hi Again Lutzer,
> >
> > The problem is not IPv6 which you may well need to access some of the
> > resources used by many applications but rather your modem's reponse to
> > IPv6 Domain Name Service (DNS) queries.  Every time you boot in or
> > likely every time you sign in DHCP will re-write /etc/resolv.conf with
> > your modem (probably at IP address <>) as
> > the first nameserver to go to.
> >
> > Best solution: Upgrade the modems firmware.  Look at it's manufacturer's
> > web page for the update info or contact your internet provider if they
> > own and support it.
> Unfortunately my DSL-Router (which includes the modem) is up to date.
> > Second best solution: By whatever means see that the modem's DNS server
> > is not used.
> >
> > Possible addition to the second solution, set up a DNS server within
> > your own box and use it as your primary name server.
> A local DNS would be faster but probably a quick solution would be to
> use a public DNS. (Any suggestions for a fast and reliable one?) How can
> I add a DNS to resolv.conf so that it is not overwritten while using DHCP?
> Thanks alot!
> Lutzer
> > I hope this helps!
> >
> > Tod
> >
> > -- google is our friend! --
> >
> --
> ubuntu-users mailing list
> ubuntu-users at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list