[breezy] No /dev/ttyUSB* is being created

Derek Broughton news at pointerstop.ca
Mon Sep 26 13:22:32 UTC 2005

Mickel-John Bunink wrote:

> I'm having a similar kind of problem with my Palm. My system also
> doesn't seem to create /dev/ttyUSB* or /dev/pilot. I've added the
> following to /etc/udev/rules.d:
> pilot.rules
> KERNEL="ttyUSB1" SYMLINK="pilot"

I don't know if that's the correct kernel name, but you should try reading
the "writing_udev_rules" file that comes with udev - check out udevtest. 
That'll help give you some idea of what's happening in udev...

> I also tried the following:
> 10-custom.rules
> BUS="usb", SYSFS{product}="Palm Handheld*", KERNEL="ttyUSB*",
> NAME{ignore_remove}="pilot", MODE="666"
> I got these suggestions from wiki's and howto's. Still no luck (yes, I
> chmodded them). Somewhere last week this was suggested in this thread:

I wouldn't want to leave that at MODE="666" but for testing, it might help

>   mknod /dev/ttyUSB1 c 188 1
>   chmod 0666 /dev/ttyUSB1

Bad idea.  The ttyUSB* devices are created when you hotplug the device - I'm
not sure that this won't just make the pilot use higher tty numbers.

 sudo modprobe visor

If that doesn't work, you can't use a USB palm device (until you install the
module).  If you get no errors from that, _then_ try syncing the palm
(specifying /dev/ttyUSB1 as the sync device).  If it works after manually
modprobing, then you have a hotplug problem.
> Although I have only a vague idea what the command mknod precisely does,
> it made ttyUSB1. But syncing the palm with gnome-pilot (pointed
> to /dev/ttyUSB1) still doesn't work. 

afaik, the palm will normally use both /dev/ttyUSB0 and /dev/ttyUSB1, though
the data transfer only happens on ...USB1.  ...USB0 is some kind of
signalling device.  You custom udev rule, above, may well be
putting /dev/ttyUSB0 onto /dev/pilot, then ...USB1 won't be able to use it.

> It still times out. Now the strange 
> thing is that I also have an external USB-drive (Lacie 250G - it rocks!)
> and have no trouble accessing that (though /dev/ttyUSB* is nowhere to be
> found ?!).

Naturally.  The external usb drive will be mounted as a scsi
device: /dev/sda if you have IDE hard drives, or /dev/sd* in any
case.  /dev/ttyUSB* are for usb serial devices.

> I have synced the palm with my current compu a year or two 
> ago with Mdk so I know it's not the cable or anything. In my quest to
> get my palm working ppl have suggested trying Kubuntu and even XP... but
> me liky Evolution (and the whole gnome experience for that matter) a

I'm sorry for you :-)  but I'll admit that kPilot is as troublesome as
gnome-pilot, here.  Probably because they're both using the same underlying
mechanism - pilot-link.


More information about the ubuntu-users mailing list