Ubuntu, Windows and my Linksys BEFSR81 Router HALF SOLVED

Derek Broughton news at pointerstop.ca
Sun Sep 25 18:15:42 BST 2005


Hodgins Family wrote:

> Good morning!
> 
>> If your router provides dynamic DNS based on these names, you can fix
>> things
>> by configuring the Ubuntu systems to send a hostname to the DHCP server.

hmm.  I see the same thing on my wireless routers, and I can't see how to
configure that - it should happen in /etc/network/interfaces - which _is_
set to send a hostname.
 
> I went into the dhcp-client configuration file and set things up so that
> the names are sent to the router and now I can see the computer names, IPs
> and MAC addresses listed in the DHCP table of the router. Beats the heck
> out of memorizing MAC addresses for each machine just so I can tell who
> has what IP!

Ah.  man interfaces tells me some DHCP clients won't use the values from
interfaces... time to submit a bug report on dhclient3.  "send ..." does
the job.
 
> Regrettably, I'm still not able to mount using the computer name...I have
> to use the IP address. In other words if I am sitting at Bar (IP
> 192.168.1.101) and try to mount ThingToMount from Foo (IP192.168.1.100) by
> typing: mount -t nfs 192.168.1.100:/ThingToMount /WhereThingIsMounted,

Can't see why not.  You are trying to use a fully-qualified domain name,
right?  What does dig tell you about Foo?  In my case, trying to nfs mount
something from the linux router running the dhcp (saxon.pointerstop.ca)
server gives me "connection refused" - which is not unexpected - and from
the other linux router - which I haven't been able to get into saxon's DNS
for probably exactly the same reasons - "mount: can't get address for
morgen.pointerstop.ca".  

So, mounting from my own system onto the same system via nfs now gives me:

derek at othello:/tmp$ sudo mount -t nfs saxon.pointerstop.ca:/usr/local /tmp/x
mount: RPC: Remote system error - Connection refused

so it would seem that once I got it into saxon's DNS I was over that hurdle.

I still think that samba mounts are probably more useful if you are going to
have a mixed Windows / Linux network, but I can't see why NFS mounts
wouldn't work.
-- 
derek





More information about the ubuntu-users mailing list