Hoary/Quake2: alsa buffer underruns

Paul M. Bucalo ubuntuser at pmbservices.com
Sun Sep 18 18:55:18 UTC 2005

Like many, I've been struggling with getting sound to work with 
Ubuntu's provided Quake2. I tried the latest loki installable version, 
as well. The latter wouldn't work, at all. I have not tried the any 
CVS versions or patches. Is it possible to get the Ubuntu version of 
Quake2 to work with ALSA?

After extensive research on the Web, I've gotten sound to work 
(modifying 'config.cfg' to look for 'alsa' for the 'snddriver'), but 
the sound output is nothing more than machine-gun sounds. One post I 
found suggested the buffer underruns problem is due to shortage of 
memory, swap space or both. I can't help but think this can't be the 
case, but maybe. :0/ Here is the specs on the machine I am having this 
problem with:

Ubuntu Hoary 5.04 (updated)
AMD K6-2/500 MHz
256 MB RAM
Mad Dog Champion MX 400 w/ 64 MB VRAM (GeForce2 MX 400 clone)
40 GB HD w/ DMA access (lots of free space left)

'config.cfg' looks like this:

// generated by quake, do not modify
bind TAB "inven"
bind ENTER "invuse"
bind ESCAPE "togglemenu"
bind SPACE "+moveup"
bind ' "invdrop"
bind + "sizeup"
bind , "+moveleft"
bind - "sizedown"
bind . "+moveright"
bind / "weapnext"
bind 0 "use BFG10K"
bind 1 "use Blaster"
bind 2 "use Shotgun"
bind 3 "use Super Shotgun"
bind 4 "use Machinegun"
bind 5 "use Chaingun"
bind 6 "use Grenade Launcher"
bind 7 "use Rocket Launcher"
bind 8 "use HyperBlaster"
bind 9 "use Railgun"
bind = "sizeup"
bind [ "invprev"
bind \ "+mlook"
bind ] "invnext"
bind ` "toggleconsole"
bind a "+lookup"
bind b "use rebreather"
bind c "+movedown"
bind e "use environment suit"
bind g "use grenades"
bind h "wave 0"
bind i "use invulnerability"
bind j "wave 1"
bind k "wave 2"
bind l "wave 3"
bind p "use power shield"
bind q "use quad damage"
bind s "use silencer"
bind t "messagemode"
bind u "wave 4"
bind x "score"
bind z "+lookdown"
bind ~ "toggleconsole"
bind BACKSPACE "invdrop"
bind UPARROW "+forward"
bind DOWNARROW "+back"
bind LEFTARROW "+left"
bind RIGHTARROW "+right"
bind ALT "+strafe"
bind CTRL "+attack"
bind SHIFT "+speed"
bind F1 "cmd help"
bind F2 "menu_savegame"
bind F3 "menu_loadgame"
bind F4 "menu_keys"
bind F5 "menu_startserver"
bind F6 "echo Quick Saving...; wait; save quick"
bind F9 "echo Quick Loading...; wait; load quick"
bind F10 "menu_quit"
bind F12 "screenshot"
bind INS "+klook"
bind DEL "+lookdown"
bind PGDN "+lookup"
bind END "centerview"
bind MOUSE1 "+attack"
bind MOUSE2 "+forward"
bind MOUSE3 "+forward"
bind PAUSE "pause"
set j_throttle "3"
set j_ud_axis "1"
set j_lr_axis "0"
set snddriver "alsa"
set hostname "noname"
set allow_download "1"
set allow_download_players "0"
set allow_download_models "1"
set allow_download_sounds "1"
set allow_download_maps "1"
set sv_reconnect_limit "3"
set s_volume "0.7"
set s_khz "11"
set s_loadas8bit "1"
set s_mixahead "0.2"
set s_primary "0"
set sndbits "16"
set sndspeed "0"
set sndchannels "2"
set snddevice "default"
set vid_ref "softsdl"
set vid_xpos "18"
set vid_ypos "85"
set vid_gamma "0.500000"
set in_mouse "1"
set freelook "1"
set in_joystick "0"
set sw_allow_modex "1"
set sw_stipplealpha "1"
set sw_mode "3"
set cd_nocd "1"
set adr0 ""
set adr1 ""
set adr2 ""
set adr3 ""
set adr4 ""
set adr5 ""
set adr6 ""
set adr7 ""
set adr8 ""
set cl_stereo_separation "0.4"
set cl_drawfps "0"
set rate "25000"
set msg "1"
set fov "90"
set gender "male"
set gender_auto "1"
set cl_vwep "1"
set g_select_empty "0"
set _windowed_mouse "1"
set skin "male/grunt"
set name "Player"
set lookstrafe "0"
set lookspring "1"
set m_pitch "-0.022000"
set hand "0"
set cl_run "1"
set crosshair "1"
set sensitivity "7"
set vid_fullscreen "1"
set viewsize "100"

Game play is slow, but playable. Sound output is my only complaint. 
Any ideas? Where to find the answers?



More information about the ubuntu-users mailing list