fetchmail stops working after upgrade to Breezy

Eamonn Sullivan eamonn.sullivan at gmail.com
Sun Sep 18 08:02:38 UTC 2005

Hi, I just noticed (a week or so after dist-upgrading from Breezy to
Hoary) that fetchmail stopped working. We use fetchmail, running via
cron once a day, for three users on my system. It fetches mail from
the ISP email account and forwards (via .forward in the home
directory) to their gmail account. This worked in Hoary, but I suspect
I modified some configuration file and have now forgotten what I did.
This is the error message from fetchmail:

14 messages for XXXXXXX at pop3.blueyonder.co.uk (297727 octets).
reading message XXXXXXXXXX at pop3.blueyonder.co.uk:1 of 14 (13595
octets) .fetchmail: SMTP connect to localhost failed
fetchmail: SMTP transaction error while fetching from pop3.blueyonder.co.uk
fetchmail: Query status=10 (SMTP)

(where XXXXXXX is the ISP username.)

I tried modifying /etc/postfix/main.cf by adding smtp.blueyonder.co.uk
to the mydestination list, but it did nothing. Same error message.

I've also noticed that /usr/bin/mail also doesn't work to deliver
message. "mail eamonn.sullivan at gmail.com" used to work, for example.

Can someone remind me how I get SMTP to work anywhere other than localhost?


More information about the ubuntu-users mailing list