netbooting via TFTP (was: non-booted Breezy install?)

Shot - Piotr Szotkowski shot at hot.pl
Mon Oct 31 11:29:00 UTC 2005


Hello.

Thanks for your answers, Daniel and Stephan!

I tried first to install from a Windows partition, but making a long
story of GRUB4DOS, WinXP MBR, mistaking swap partition with /boot and
the like a short one, I'm now left with absolutely unbootable laptop. :o)

Stephan Hermann:

> can u pxe boot somehow?
> 
> If yes, https://wiki.ubuntu.com/Installation/LocalNet
> or https://wiki.ubuntu.com/Installation/Netboot
> 
> The first one helped me a lot with my portege.

I almost have the LocalNet instructions working - did everything
as written, the laptop even finds the DHCP, but ends with
PXE-E32: TFTP open timeout

Is there a way I can check whether the TFTP server is visible from the
local network? The Netboot instructions say something about enabling
TFTP server in xinetd, but I don't have xinetd installed (the server
box is a vanilla Breezy install with just tftpd-hpa, apache2 and
dhcp3-server added as per the instructions); the LocalNet ones
suggest that just installing tftpd-hpa should be enough.

FWIW, I tried both filename="pxelinux.0"; and
filename="ubuntu/install/netboot/pxelinux.0";
and I can get to the files via Firefox, so it
doesn't seem to be a problem with file permissions.

Cheers,
-- Shot
-- 
    It's clear that whoever set up the font colorings for most programming
    modes has seen too many Peter Max posters, or did more acid than I did
    in the 60s.                       -- Charles R. Martin, gnu.emacs.help
====================== http://shot.pl/hovercraft/ === http://shot.pl/1/125/ ===
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20051031/e67f5230/attachment.pgp>


More information about the ubuntu-users mailing list