web photo gallery builders in Gnome?

Timothy A. Holmes tholmes at mcaschool.net
Fri Oct 28 19:03:58 UTC 2005

-----Original Message-----
From: ubuntu-users-bounces at lists.ubuntu.com
[mailto:ubuntu-users-bounces at lists.ubuntu.com] On Behalf Of Dan Martin
Sent: Friday, October 28, 2005 1:26 PM
To: 'Ubuntu Help and User Discussions'
Subject: RE: web photo gallery builders in Gnome?

> I hate to sound like more of an ID1OT than I have to, but im 
> a bit lost here
> I downloaded jalbum
> Copied it to /opt
> Ran ./JAlbuminstall.bin
> Got a message that it required a java virtual machine Looked 
> up (under restricted formats) how to install the JDK 
> Downloaded that Installed it according to the instructions 
> Amazingly it appeared to install properly (if at first you do 
> succeed try not to look surprised) (it was my first build in 
> UBUNTU) Tried installing jalbum again Getting an error that 
> says there is no java virtual machine in my path 
> Sorry for all the questions folks, this learning curve is 
> just a lil steep

Not at all, I've been through the same trouble.  It's not easy stuff.
default, Ubuntu has Gnu Classpath set up for "java stuff".  When you
another Java package (Sun's Java, for as you've done), you need the Sun
"java" binary to be prior to Gnu Classpath's "java" binary in the
or Gnu Classpath gets called instead of Sun's "java" binary.

I'm willing to bet if you type "java -version" you'll see the GCJ

Two possibilities:  
1) You installed using the extra repositories.
2) You installed by downloading the JDK yourself (perhaps using

If you did 1), your environment has probably been set, and you simply
to log out and back in.  If you did 2), you need to set your environment
manually.  You will need to do something like this:

export JAVA_HOME=/usr/lib/j2sdk1.5-sun/
export PATH=/usr/lib/j2sdk1.5-sun/bin:$PATH

After that, type "java -version", and you should no longer see the Gnu
classpath stuff, but rather the standard Sun output:
java version "1.5.0_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_05-b05)
Java HotSpot(TM) Client VM (build 1.5.0_05-b05, mixed mode, sharing)


ubuntu-users mailing list
ubuntu-users at lists.ubuntu.com
[Timothy A. Holmes]


Thanks so much for your help -- that solved it, and Jalbum is now

Could you please explain what I just did?  I have seen the export
command, but I don't think that I have ever used it before



Timothy A. Holmes
IT Manager / Network Admin / Web Master / Computer Teacher
Medina Christian Academy
A Higher Standard...
Jeremiah 33:3
Jeremiah 29:11
Esther 4:14

More information about the ubuntu-users mailing list