OpenOffice 2.0 - Manual Installation

Ryan Escarez ryan.escarez at
Fri Oct 28 05:39:10 UTC 2005

On 10/28/05, Alfred Vahau <Alf.Vahau at> wrote:
> Hi,
> I downloaded OpenOffice 2.0 and unpacked it into a temporary directory.
> When I attempted to install the rpm
> packages, it failed and instead a message appeared pointing to the use
> of alien program. This program was
> ran on the rpm packages and converted them to debian ones with extension
> deb.
> I run the dpkg --install <package_name> but this failed to find the package.
> I also tried use apt-get install but this failed to find the packages
> too. I looked up the sources.list file under /etc/apt
> and found that the reference was to packages on the CD Rom (in my case
> the Warty distribution).
> I commented out that line and inserted a line with the path to the
> temporary directory containing the openoffice2.0 files.
> It looked like this:
> deb /path/to openofficef files
> I executed the apt-get and dpkg --install commands again but these fail
> to find the packages.
> How can I tell apt-get to look in the temporary  directory and install
> the openoffice2.0 files?

as you download OO.o for manual installation you don't have to use
apt, instead tell dpkg to do it, in the first error you are trying to
install a rpm package wich is need to be converted into deb files. the
following work around will solve your day.

conver first all the rpm files and tell dpkg to install it
$ sudo alien *rpm
$ sudo dpkg -i *deb


Ryan Escarez
CEBB F1E4 1E39 EC48 F05D  6B72 9C11 DD88 5E39 E471
$ gpg --keyserver --recv-keys 0x5E39E471
main(k){float i,j,r,x,y=-16;while(puts(""),y++<15)
for(x=0;x++<84;putchar(" .:-;!/>)|&IH%*#"[k&15]))

More information about the ubuntu-users mailing list