Yaboot problem

Steve Didier steve.didier at gmail.com
Tue Oct 25 19:01:28 UTC 2005

If you haven't recieved an answer yet suggest that you go to
http://penguinppc.org/bootloaders/yaboot/doc/yaboot-howto.shtml/ and
read the how-to there. The manual ha shelped me alot!
It sounds to me that you did not configure an Apple Bootstrap
partition (typically that would be /dev/hda2 on your internal drive)
and that you are trying to boot from your root partition. You need at
a minimum two partitions--one 800MB bootstrap partition and one /
partition--although most instalations also have you create or create
by default a swap partition that is at least 256mb in size-usually no
more than 512--

Hope this helps!

On 10/23/05, Mauro K. T. Tojo <maulista at uol.com.br> wrote:
> Hi all,
> I was really looking forward to testing ubuntu on my iMac G3 400 and
> I've spent more than 10 hours reading articles and trying to install it.
> I tried to install:
> 1) On a partition on my ext FW drive
> 2) On a partition of my internal HD
> 3) Erasing my internal HD completely and installing only ubuntu
> Problem is, everything always goes well until yaboot installation. It
> NEVER installs, stops at 83% and fails. And I've tried creating all
> the partitions myself and also letting the installer do it
> automatically, everything that you can imagine (non-commandline wise)
> I've tried.
> Right now the Ubuntu system is in my third partition, hda3, and I
> just can't boot it because yaboot never manages to install in the
> bootstrap partition (number 2). If I try to boot it from the CD
> yaboot via hd:3,/boot/vmlinux kernel it boots from the installed
> system in my HD but stops because it says there is no root argument
> (asks me to append a valid root argument, which I guess is root=/dev/
> hda3)
> Can anyone help me?
> Thanks a lot.
> --------
> Kioshi
> http://kioshi.org
> http://meiobit.com
> http://fotolog.net/kioshi

More information about the ubuntu-users mailing list