'Forum Post ulist at
Sun Oct 23 17:11:18 UTC 2005

Here are my experiences with the Citrix Client.

Before upgrading I was running Hoary on a 32bit system and a 64bit AMD
system. Both were successfully running the v9 ICA Client. After
upgrading to Brezzy on the 32bit system, I was able to continue using
the v9 ICA Client without any trouble. It worked just as it had before.
Not so for the 64bit system. Trying to start an app from my companies
site results in nothing. After reading this thread, here is what I see
for diagnostic info:

root@:/usr/lib/ICAClient# ldd wfica =>  (0xffffe000) => not found => /usr/lib32/ (0x5557c000) => /usr/lib32/ (0x555ca000) => /lib32/tls/ (0x5568a000) => /lib32/tls/ (0x5568d000) => /usr/lib32/ (0x557bb000) => /usr/lib32/ (0x557c8000) => /usr/lib32/ (0x557d0000) => /usr/lib32/ (0x557e9000) => /usr/lib32/ (0x557ec000)

/lib/ (0x55555000)

root@:/usr/lib/ICAClient# locate






root@:/usr/lib/ICAClient# ./wfica

./wfica: error while loading shared libraries: cannot open
shared object file: No such file or directory

Why the error locating and loading the library when the locate command
says that it is present? I've installed libmotif3 (2.2.3-1) and every
other recommendation I could find in this thread except to install the
German v8.2. Still no luck. I've noticed that LD_LIBRARY_PATH is not
set. On other unix systems that I've used, I often had to set this env
variable. What is the default when this is not set?


More information about the ubuntu-users mailing list