Setup pppoe on install/livecd

'Forum Post ulist at
Sun Oct 23 04:32:57 UTC 2005

I've also been pulling my hair trying to figure out what happened to my
formerly working pppoe setup under Hoary yesterday. Last week I had
BT'ed both Breezy Live and Install CDs in preparation for upgrade and
turns out that the Breezy Live fails with pppoe(conf) as well.

Anyway, I usually kept Hoary up and connected for weeks on end,
downloading security fixes as they appeared, but yesterday after reboot
the usual "sudo pon dsl-provider" failed. I had to resort to using
MCNLive (mandriva mini-derivative) to get online and try finding out
what had happened.

Well the first issue was that the previous "ppp0" interface had changed
into "sit0", but the suggested IPv6 -> IPv4 switch didn't help (sit0
went away but ppp0 never returned). I tried the recent pppoeconf tip
(bug# 10334) too but no use. Maybe it made the setup even more
dysfunctional but I wouldn't know. But now Loopback gets all the test
traffic and eth0 just sits there, nominally in active state but getting
no traffic. ppp0 just doesn't come up.

Under MCNL my pppoe "modem" (Marvell 88E8001 Gigabit Lan PCI controller
onboard ASUS A7V880 mobo) uses the sk98lin module but Hoary (or Breezy
Live) doesn't seem to load it, and if I modprobe it manually it doesn't
seem to be linked anywhere. Adding it in /etc/modules made no

Hoary's hardware data tool's information also looks sparser than I
recall so I wonder if the newish hotplugging(?) system was somehow
affected by the security updates. I've no idea why Hoary's pppoe failed
after the reboot or why pppoeconf under Breezy fails to get the "access
concentrator" from my DSL "modem" but since Mandriva's network setup
tool has no trouble whatsoever it's not a hardware failure.

I've been using Linux for years and I'm not afraid to edit
configuration files, but there may be a couple of dozen relevant files
in various places and without a degree in networking it's quite hard to
know what should be in each of them, and what shouldn't, or in what
order. But pppoe under Hoary worked and suddenly stopped without any
intentional action on my part.

Would it be practical for Ubuntu to consider adopting Mandriva's
all-in-one network setup tool (GPL, GTK)? At least the initial
configuration of anything network-related would be approachable to new
users, but that would still leave troubleshooting (like my current
issue) needing howto's or certified voodoo priests.

I've trawled the ubuntuforum and google for ideas but they seem to be
predominantly about DHCP issues which in my case may lead to even more
confused configuration.  :-/

Just installing Breezy over Hoary (from CD) isn't very appealing either
when Breezy Live has also problem with pppoe (or getting the access
concentrator) and without network access post-release updates and fixes
won't be available...


More information about the ubuntu-users mailing list