alsa-space: xrun of at least 0.007 msecs. resetting stream

'Forum Post ulist at
Mon Oct 17 07:00:30 UTC 2005

I am getting this same error on some video files with mplayer.  

Putting this in my .mplayer/config file stopped it for me:


But I don't think this is really solving the problem entirely.  One of
the files that was skipping in mplayer would play smoothly in
totem-xine but then locked the whole system.  I use a ~.asound file
which never gave me issue before breezy but I tried moving it with no
effect.  I also noticed xmms seg faults randomly, not sure if it's
related.  I don't think it's a 1.09 related issue, as I run my own
kernel and have been for awhile in hoary and I'm still using the same
kernel in breezy and getting this error.  I tried recompiling alsa but
it was no help.

My alsa config looks like this:







But I've gone back and tried it as ao="alsa" instead of using my dmix
with no effect.

I was kind of surprised to find a hoary thread on this problem as this
problem just cropped up with breezy for me.  It happens on video that
I've had awhile and didn't give me issue in mplayer before.  I also
tried compiling a new kernel from the ubuntu source for 2.6.12 but the
same.  I thought it would be a kernel issue but my old kernel that I
used for months in hoary has the same issue.


More information about the ubuntu-users mailing list