Ubuntu as print server

Al Gordon runlevel7 at gmail.com
Sun Oct 16 21:02:06 UTC 2005

On 10/16/05, Chosechu <chosechu at gmail.com> wrote:
> Dear all:
> The subject must have come up a hundred times I'm sure,
> but I cannot find anything useful on the Net about that
> topic. Simple question: how do I set up cups to be a LAN
> print server?
> I tried modifying /etc/cups/cupsd.conf to no avail. Lots
> of redundant things here, too many ways to customize
> security settings. So many actually that the only thing you
> want to do in the end is disable security features completely.
> Too much security killed security, it seems.
> First I changed the "Listen" line to add some more, got
> some errors, then reverted back to something simpler:
> Port=631 and nothing else.
> Setting "Allow from All, Deny from None" did not seem to do
> the job either. I get no complaints but it still does not
> work.
> Next I tried browsing on localhost:631.
> Took me some net browsing too before I could figure out that
> you need to add up some passwords specifically for CUPS with
> 'lppasswd'. Try as I might, I added several passwords and
> users and then users/passwords to no avail. I finally got
> through by making 'cupsys' member of the 'shadow' group and
> log in with my own user account. Now 'cupsys' has probably
> gained some ways to corrupt my system but oh well... If
> anybody has some detailed insight as to why 'lppasswd' does
> not work on my system?
> Finally I got some administrative-like interface inside a
> web browser, but strictly nothing to set up network stuff.
> There is a message mentioning the use of a GUI in
> Administration/Printing but this one does not have anything
> about printer sharing or network configuration.
> Stuck in square one. Anyone willing to point me to a simple
> configuration tool or a braindead HOWTO for dummies? I am
> trying to print from a Mac and the poor machine does not see
> anything about my Ubuntu cups server. What should I do?
> Thanks for helping
> --
> Chosechu <chosechu at gmail.com>

I just tried thisout for myself.

With a fairly stock /etc/cups/cupsd.conf (only modified previously by
adding a printer via the Administration, Printing app) I commented out
the line:


and uncommented the line

#Port 631

Now, granted, I haven't printed to it yet (no other PCs around, at the
moment), but nmap shows port 631 now listening on localhost as well as
my eth0 interface.

I hope this helps.


  -- AL --

More information about the ubuntu-users mailing list