realplayer 10 (x86) on 5.10 (AMD64)

Tristan Wibberley maihem at
Sun Oct 16 19:24:53 UTC 2005

Tristan Wibberley wrote:
> Hi,
> I'm trying to run realplayer 10 on breezy. I don't know how everything
> is structured for 32-bit support within the AMD64 version of breezy, but
> the appropriate libraries seem to be in /lib32 and /usr/lib32 and ldd
> realplay.bin shows library references resolving to files in those
> directory trees.

I've made some progress by referring to
/usr/lib64/openoffice2/program/soffice.bin, but I still get this message:

Failed to load pixbuf file:
/usr/local/RealPlayer/share/realplay/icon.png: Unable to load
image-loading module:
/usr/lib/gtk-2.0/2.4.0/loaders/ cannot open
shared object file: No such file or directory

(I get some others but I expect to get them). The bit of code that loads
the pixbufloader seems to be ignoring the GTK_PATH. I've tried making a
copy of /etc/gtk-2.0/gdk-pixbuf.loaders in /etc32/gtk-2.0 and changing
the paths to /usr/lib32/... and exporting an environment variable
GDK_PIXBUF_MODULE_FILE=/etc32/gtk-2.0/gdk-pixbuf.loaders but that hasn't

Any ideas?

Tristan Wibberley

More information about the ubuntu-users mailing list