Audio playback problems

August Karlstrom fusionfive at
Sat Oct 15 23:33:02 UTC 2005

crimsun at wrote:
> On Sat, Oct 15, 2005 at 09:41:26PM +0200, August Karlstrom wrote:
>>When I play an mp3 file with Rhythmbox or Totem (totem-xine) it's played 
>>in something like half speed (probably wrong sample rate) and only 
>>through the left channel. If I play the file as superuser (sudo) there 
>>are no problems. Any clues?
> What is System> Preferences> Multimedia Systems Selector> Default Audio
> Sink configured as? 

Default Sink: ESD
Default Source: OSS

When I run the sink test I hear a sound in the left channel only (as 
before). The source test (for OSS) produces no sound.

(I've had the impression that OSS is obsolete and to be replaced by ALSA.)

> If it's currently esdsink, please switch to Custom,
> and in the text entry box beneath the drop-down menu, please type:
> alsasink device=plug:dmix

With this setting I get an error when I run the test:

    Failed to construct test pipeline for 'Custom'

> If that fails to work correctly, please use:
> alsasink device=plughw:0

Same error here.

Since everything works when I'm superuser the solution can't be that far 
away. It has to be some file permission issue.


More information about the ubuntu-users mailing list