rsnapshot - cannot create links errors - unable to use

Carthik Sharma carthik at
Fri Oct 7 19:34:10 UTC 2005

On 10/7/05, Carthik Sharma <carthik at> wrote:
> Hi,
> I thought it might be neat to try and backup my home and etc directories
> to an external USB hard disk drive on a weekly basis and so I tried to use
> rsnapshot.
> The USB drive is auto-mounted by Ubuntu to /media/work-usb
> The error I get is :
> /bin/cp: cannot create link
> `/media/work-usb/carthik/rsnapshot/weekly.1/localhost/etc/fstab': Operation
> not permitted
> /bin/cp: cannot create link
> `/media/work-usb/carthik/rsnapshot/weekly.1/localhost/usr/local/lib/texmf/ls-R':
> Operation not permitted
> /bin/cp: cannot create link
> `/media/work-usb/carthik/rsnapshot/weekly.1/localhost/usr/local/share/fonts/fonts.cache-1':
> Operation not permitted
> ERROR: /bin/cp failed. Perhaps this is not GNU cp?
> ERROR: Error! cp_al("/media/work-usb/carthik/rsnapshot/weekly.0/",
> "/media/work-usb/carthik/rsnapshot/weekly.1/")
> /usr/bin/logger -i -p user.err -t rsnapshot ERROR: Error! \
> cp_al("/media/work-usb/carthik/rsnapshot/weekly.0/", \
> "/media/work-usb/carthik/rsnapshot/weekly.1/")
> rm -f /var/run/
> (I deleted all but the last three "cannot create link" errors to save us
> some space)
> relevant settings from the /etc/rsnapshot.conf file are as follows:
> snapshot_root /media/work-usb/carthik/rsnapshot/
> interval weekly 4
> backup /home/carthik/ localhost/home/carthik/
> backup /etc/ localhost/etc/
> backup /usr/local/ localhost/usr/local/
> It creates some directories, but then errors out saying it cannot create
> the links.
> I am running it using "sudo rsnapshot weekly"
> Any help to figure out why it cannot create the links is welcome. I really
> thought I was all set for easy backing-up but it looks like I'll need some
> help after all :)
> Thanks in advance,

Update: I tried to manually create a (hard) link : The results follow :

carthik at milan:/media/work-usb/carthik/rsnapshot/weekly.0/localhost/etc$ ln
ln: creating hard link
`/media/work-usb/carthik/rsnapshot/weekly.1/localhost/etc/adduser.conf' to
`adduser.conf': Operation not permitted

So why can't I create links on the external USB hdd ?

Thank you,

Ph.D. Candidate
University of Central Florida
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list