[Dapper] nVidia (restricted driver issue)

Mario Vukelic mario.vukelic at dantian.org
Tue Nov 29 09:01:54 UTC 2005

On Mon, 2005-11-28 at 23:09 -0500, Darryl Clarke wrote:
> Everything works ok with the plain old 'nv' driver in my xorg.conf
> except for all the bonus features (dual screen, OpenGL support) I
> want. ;)
> The kernel nvidia module loads on boot
> Then xorg fails with this:
> (II) LoadModule: "nvidia"
> (WW) Warning, couldn't open module nvidia
> (II) UnloadModule: "nvidia"
> (EE) Failed to load module "nvidia" (module does not exist, 0) 

I have the exact same problem on Dapper, only in my case it is the
proprietary ATi driver (fglrx) that won't work, while the free "ati"
driver does work (but had stopped for a while too)
Plus, the synaptics touchpad driver leaves the same error in the X log
file ('Failed to load module "synaptics"').

I guess the drivers just have to be rebuilt against the current X
version, but I haven't tried yet: 
On Nov 24, there was an update xserver-xorg-core 6.8.2-77 ->
1:0.99.3-0ubuntu2. Nearly all the rest of X was not updated at that
time. A few days later X wouldn't restart (I hadn't rebooted earlier),
even with the free ati drivers.
Then on Nov 26, the rest of X was aso upgraded. While before, each
xorg-driver-* package had been at 6.8.2-77, now they all have different
version numbers, maybe there is X modularization work going on.

Anyway, xorg-driver-fglrx was not upgraded and, as I said, I guess woud
have to be rebuilt and upgraded. Same would be my guess for nvidia.

Kind regards, M

More information about the ubuntu-users mailing list