mpd: Does not install correctly

Håvard Dahle havard at aerosat.co.za
Mon Nov 21 21:16:40 UTC 2005


Package: mpd
Version: 0.11.5-4ubuntu1
Severity: important


Trying to install mpd mysteriously fails:

> havard at rasha:~$ sudo apt-get install mpd
> Reading package lists... Done
> Building dependency tree... Done
> mpd is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> 1 not fully installed or removed.
> Need to get 0B of archives.
> After unpacking 0B of additional disk space will be used.
> Setting up mpd (0.11.5-4ubuntu1) ...
> Stopping Music Player Daemon: mpd... MPD is not running.
> MPD db at /var/lib/mpd/mpddb not found, creatinginvoke-rc.d: initscript
> mpd, action "restart" failed.dpkg: error processing mpd (--configure):
> subprocess post-installation script returned error exit status 1
> Errors were encountered while processing:
> mpd
> E: Sub-process /usr/bin/dpkg returned an error code (1)

What am I doing wrong? 

This is a hoary install updated to breezy. I have never had any mpd
package on this system.


Thanks,



-- System Information:
Debian Release: testing/unstable
  APT prefers breezy-updates
  APT policy: (500, 'breezy-updates'), (500, 'breezy-security'), (500, 'breezy')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-9-k7
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages mpd depends on:
ii  adduser                3.64ubuntu1       Add and remove users and groups
ii  debconf [debconf-2.0]  1.4.56ubuntu2     Debian configuration management sy
ii  libao2                 0.8.6-1ubuntu3    Cross Platform Audio Output Librar
ii  libasound2             1.0.9-2           ALSA library
ii  libaudiofile0          0.2.6-6           Open-source version of SGI's audio
ii  libc6                  2.3.5-1ubuntu12   GNU C Library: Shared libraries an
ii  libflac7               1.1.2-1ubuntu2    Free Lossless Audio Codec - runtim
ii  libid3tag0             0.15.1b-7         ID3 tag reading library from the M
ii  libmad0                0.15.1b-2.1       MPEG audio decoder library
ii  libmikmod2             3.1.11-a-6ubuntu2 A portable sound library
ii  libogg0                1.1.2-1           Ogg Bitstream Library
ii  libvorbis0a            1.1.0-1ubuntu1    The Vorbis General Audio Compressi
ii  libvorbisfile3         1.1.0-1ubuntu1    The Vorbis General Audio Compressi
ii  zlib1g                 1:1.2.3-3ubuntu4  compression library - runtime

mpd recommends no packages.

-- debconf information:
* mpd/systemwide: true
  mpd/port: 6600
  mpd/port_changed:
* mpd/music_directory: /mnt/felles/musikk
* mpd/playlist_directory: /usr/share/mpd/playlists
  mpd/restart: false
  mpd/state_file: true




More information about the ubuntu-users mailing list