Read-only access on mp3 player, how to fix? Addenum

Anthony Dean adean75 at sbcglobal.net
Tue Nov 22 02:11:47 GMT 2005


On Mon, 2005-11-21 at 10:30 -0500, John DeCarlo wrote:
> On 11/21/05, Anthony Dean <adean75 at sbcglobal.net> wrote:
>         I'm having trouble getting a Sandisk Sansa mp3 player (the
>         e240 model)
>         to work with Ubuntu (Breezy). At first, it let me copy files
>         to and from
>         it (upon plugging it in via the USB port... it's supposed to
>         work as a
>         removable USB drive), but then it suddenly wouldn't let me
>         delete or
>         copy files to or from the player, giving me "read only disk"
>         error
>         messages. 
> 
> 
> 
>         /dev/sda1 on /media/sandisk type vfat
>         (rw,noexec,nosuid,nodev,uid=1000,user=<myusername>)
> 
> Have you tried copying or deleting using sudo?  (sudo
> rm /media/sandisk/song.mp3)
> 
> It seems like your fstab entry is correct, based on the above report
> from mount.  
> 
> You can also use fsck.vfat to see if the file system is messed up.

I tried "sudo rm /media/sandisk/song.mp3", but get the "read only disk"
error message. I can copy files from the player to my home directory,
though.

How do I use fsck.vfat?

After more messing with the directions on Ubuntu Guide (for manually
mounting Windows FAT partitions), in addition to the /etc/fstab editing,
I got this as "mount":

>>/dev/hda3 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
tmpfs on /lib/modules/2.6.12-9-386/volatile type tmpfs (rw,mode=0755)
/dev/hda1 on /boot type ext3 (rw)
/dev/hda2 on /home type ext3 (rw)
tmpfs on /dev type tmpfs (rw,size=10M,mode=0755)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sda1 on /media/sandisk type vfat (rw,iocharset=utf8,umask=000)
<<

Directions followed for mounting it manually:
sudo mkdir /media/sandisk
sudo mount /dev/sda1 /media/sandisk -t vfat -o iocharset=utf8,umask=000

And yes, I checked---the "hold" button is set to off. :-)

Not sure what else to do right now... maybe permissions need to be
changed somewhere (or adding a user name(s) to a group, though not sure
how to do that exactly)?

Anthony
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : https://lists.ubuntu.com/archives/ubuntu-users/attachments/20051121/f580ba95/attachment.pgp 


More information about the ubuntu-users mailing list