[Breezy] Reiser4

Jimmie Houchin jhouchin at cableone.net
Thu May 26 14:55:42 UTC 2005

Ed Cogburn wrote:
> Jimmie Houchin wrote:
>>I am considering Reiser4 on one of my computers.
>>Is it stable enough yet?
>>Is it supported by the standard kernels or will I need to compile my own?
>>This will be on an Athlon64 machine if that makes any difference.
>>Also, this is with Breezy.
> Hi, Jim
> R4 is still unstable for some,  Its still breaks for me, I last tried it ~3
> months ago and it locked up within 2 minutes after mounting during a large
> cp -a operation, and I'm on an AMD64.  ReiserFS (R3) is just fine here
> though, FWIW.
> As the other poster said though, you'll have bigger problems with the rest
> of Breezy as its currently even more unstable than R4 is.  Ok, ok, that's
> the polite, PC way of saying its completely *borked* right now.  :)  I've
> got nearly all of Breezy on hold in aptitude waiting for things to settle
> down.
> If you intend to use that other computer within the next 6 months or so as a
> production platform (getting real, important work done), I would avoid
> using either R4 or Breezy on it, *if* you can.  I can understand the
> problem with R4, there is no other Free filesystem quite like it at the
> moment which is why every couple of months I try it again to see if it
> works for me.  Alas, so far it doesn't.  Would have tried it again already,
> but the last 2 releases of Andrew Morton's -mm kernel patches (with R4
> included) panic on bootup for me.  That's life on the bleeding edge for
> 'ya.  Sigh.
> Ed

Hello Ed,

Thanks for the reply and for yours too Vincent.

Yes, I fully (painfully so) aware of the problems with Breezy. 
Unfortunately it is the only Ubuntu that has successfully installed onto 
this machine. My machine is a DFI LanParty UT nF3 250Gb motherboard, 
Athlon64 3000ghz cpu, 1gb ram,120gb ide drive and or 250gb sata drive.

Warty and Hoary installs are seemingly okay. But upon boot I get errors 

Id "1" respawning too fast: disabled for 5 minutes
Id "2" respawning too fast: disabled for 5 minutes
Id "3" respawning too fast: disabled for 5 minutes

cannot execute "/sbin/getty"
cannot execute "/bin/sh"

I posted about this problem March 8, no replies. So it seems to be an 
uncommon problem. (I also recently upgraded my dual Opteron server from 
Warty to Hoary. Ugh! Same errors.) Soon after I tried Breezy and 
installed and ran successfully. I've been running Breezy since. It 
hasn't been what I call stable, but it has been usable. When you still 
have to use Windows computers (at work) you sometimes have low standards 
with regards to stability. :)

Then I did an update/upgrade. I got bit by the X issue. So I've decided 
to install on the other hard drive so that I could have one drive which 
follows the updates until they work again. The other drive can stay put 
in a reasonably (so so) stable state. At least usable.

Back to R4. It just looks so attractive based on the information. But I 
know it may not have totally stabilized yet. The latest post I 
remembered to this list was in March. So I just thought I would test the 
waters again.

I might just compile me a kernel give it a try on separate partition 
using it for trivial data (log files or such) and duplicate data. When 
its at a point I can trust. Then move on. But like you say. That 
probably won't be til Breezy itself is on the stable side.

Ubuntu is the Linux I want to use. I've used RedHat, Debian, Gentoo, and 
since Ubuntu first came out, Ubuntu. It just seems to hit a good place 
in the Linux world.

Thanks again for your reply.


More information about the ubuntu-users mailing list