Colony CD 1 (quick report)

Vincent Trouilliez vincent.trouilliez at
Wed May 18 07:18:05 UTC 2005

> They won't be spot on two weeks during the first part of the
> development process, as it probably won't be installed for a while.
> We're upgrading to gcc4, true, but this hasn't affected the first
> Colony -- it only started late last night, after Colony 1's release.
> Cheers,
> Daniel

Ah, thanks. I went to download the ISO then... :-)
Here is a quick first impression report :

1) ddcprobe still fails to detect my monitor, despite my 3 year old copy
of Win XP can, so I dare to think that it's not a H/W problem and that
Linux should be able to do it too...  We discussed this in my bug
report, which is closed... would be nice to reopen it, otherwise might
never get looked into/fixed ?

I can't wait for the H/W database's front end to be finished, so I can
hopefully find someone with the same MSI nForce motherboard as me, and
ask them how ddcprobe goes on their board.
Thanks God, although annoying, it's very easy to fix by hand.

2) Main/show-stopper problem now : Network card problem: DHCP
configuration failed during installation, for the first time ever. Then
just after I log-in, and even before starting to load the desktop, Gnome
greets me with this message : 

"Could not look up internet address for "Lotus-Esprit". This will
prevent Gnome from operating correctly. It may be possible to correct
the problem by adding Lotus-Esprit to the file /etc/hosts
 [Log in anyway]  [Try again] "

I click on "log in anyway" and the desktop comes up fine, no apparent
ill effect. I then rush to open the device manager. The network card is
detected and identified properly (cheapy generic add-on Realtek 8139
card), and it is assigned to "eth0".
But it won't work anyway. If I click on the network status applet in the
to panel, it won't open, complaining that no network devices could be
found, it won't even show 'lo', just won't open at all. Then if I try to
go to System -> Administration -> Networking, to see if I can bring ethO
up, it won't even start. :-/
So with no network, I can't test much. In particular I wanted to
download/install XawTV to see if the kernel had been patched as stated
in bugzilla, to make my TV card work properly.

Still about ddcprobe, I tried running it from a terminal, and it failed,
stating that it could not connect to Lotus-Esprit or something. This one
really confuses me... what does probing the monitor have with anything
network related ?? :o( 

3) SCSI CD writer is all set up verynicely in nautilus, nice icon in the
"Computer" location, can read CD's, but can't burn anything. If I insert
a blank disk, it is detected, Nautilus puts an icon on the desktop, and
opens the "CD/DVD burning" location/window for me to drop files into.
But when I click on "Write to disc", it asks me to insert a blank CD,
ove ran over again, despite 10 seconds before that, it obviously noticed
said blank CD. Looking at /var/log/messages, the kernel throws bags of
varied errors to do with the drive... not sure what it doesn't like, the
drive or the SCSCI controller (low-end Adaptec card), or both. At any
rate, both worked fine when I burned the Colony ISO in Win XP, so again,
I dare to believe that Ubuntu can sort things out :o)

4) A "problem" with the partitioner during the install. Nothing went
wrong technically, but I was a bit surprised/scared by the user
interface itself. I chose manual partitioning. Then change my mind and
clicked on "guided partitioning", and selected "erase entire hdb". then
it computed the partitions, and took me back to the partitionner to show
me the results/details. This is where I was a bit "scared" : the two
partitions it created (/ and swap) on hdb were marked as "won't
format" (the "smiling face"/icon), whereas they obviously were to be
formatted (and indeed were, of course), so should have been flagged with
the "death" icon instead. Problem is that, being obvious that I could
not trust the icons anymore, how could I be sure that my other partition
(on hda), which contain Hoary and my data, would not be messed with ?

I uploaded all the files of /var/log/installer there, if it's any
help :

I guess that partman will tell all about what happened when
partitioning, but since technically, all went well, I am not sure if it
will tell you what icons/smileys where displayed by the UI ?
Well at least, it may help reproduce the problem...

To add a positive note ;o) my old AGFA Snapscan SCSI scanner now works
perfectly out of the box, after much debate with Warty and Hoary. Now,
Hotplug dares to load the 'sg' module at boot, and then, I can at last
use it as a normal user, instead of root only.  So it's sweet as
chocolate now, I appreciate very much... :o)


More information about the ubuntu-users mailing list