GRUB Re-Install

Vram lamsokvr at
Fri May 6 06:17:47 UTC 2005

Matthew S-H wrote:

> *_NOTE: I have some questions at the /end/, so if anyone does not care to
> read by explanation of how I fixed the problem but is still willing to 
> help
> me, just scroll down._*
> I'm SOOO sorry to have wasted all of your time.
> I just figured out a way to get my computer to boot /temporarily/. I 
> did the following:
> Booted off the Live CD.
> Pushed escape and then enter to go to the non-gui boot list.
> Pushed "c" to go to a GRUB command line.

type e for edit...

init=/bin/bash  rw

this should take you to a command prompt..

as root...


mount the rest of the partitons

mount -a ?<I think>

then cd /boot

type GRUB.

and reinstall grub...

Something like that..

Good luck

May the force be with you;..

> Typed it the following:
> root (hd1,9)
> kernel /vmlinuz-2.6.10-5-386 root=/dev/hdb9 ro quiet splash
> initrd /initrd.img-2.6.10-5-386
> boot
> And viola!! Everything booted fine.
> Of course, I already had edited my /etc/fstab and /boot/grub/menu.lst 
> files
> before-hand.
> Anyway, now that that is all said and done, any tips on how to reinstall
> GRUB so that I don't have to boot off the CD and type that at each boot?
> I tried running the following:
> [Note that I am now able to copy-paste because I can boot into my Hoary
> installation and use Evolution. It'll be much easier now for me to 
> give all
> of you the output I get from commands (before I was typing it all up 
> manually)]
>     [me]@[foo]:~$ sudo grub-install --recheck --root-directory=/ /dev/hdb
>     Password:
>     Probing devices to guess BIOS drives. This may take a long time.
>     Due to a bug in xfs_freeze, the following command might produce a
>     segmentation
>     fault when //boot/grub is not in an XFS filesystem. This error is
>     harmless and
>     can be ignored.
>     xfs_freeze: specified file ["//boot/grub"] is not on an XFS
>     filesystem
>     Installation finished. No error reported.
>     This is the contents of the device map //boot/grub/
>     Check if this is correct or not. If any of the lines is incorrect,
>     fix it and re-run the script `grub-install'.
>     (fd0) /dev/fd0
>     (hd0) /dev/hda
>     (hd1) /dev/hdb
>     [me]@[foo]:~$
> Anyway, I rebooted and got the same Error 15.
> Any ideas on how to reinstall GRUB to the MBR or what I might be doing 
> wrong?
> ~Matt
How about hit


More information about the ubuntu-users mailing list