GRUB Re-Install

Matthew S-H mathbymath at
Fri May 6 06:10:25 UTC 2005

I'm sorry, I must sound like a 5 yr-old, but I'm just excited.

I fixed it!!!!

I did everything below, except I changed "/dev/hdb" to "/dev/hda".  I 
was reading
an article slaves and master drives and realized that maybe the system 
looking at the MBR of "/dev/hda" instead of "/dev/hdb".  So I solved 
the problem
by installing it on "/dev/hda".

Anyway, I would like to send out a nice thank you to everyone for your 
ESPECIALLY cmorgan047 at .
Without you guys I'd probably be stuck with a fresh install on a 
reformatted drive.
Or, worse yet, stuck in Windows for fear of losing my data.  Anyway, 
thank you
all for your help.


On May 6, 2005, at 2:01 AM, Matthew S-H wrote:

> NOTE:  I have some questions at the end, so if anyone does not care to
> read by explanation of how I fixed the problem but is still willing to 
> help
> me, just scroll down.
> I'm SOOO sorry to have wasted all of your time.
> I just figured out a way to get my computer to boot temporarily.  I 
> did the following:
> Booted off the Live CD.
> Pushed escape and then enter to go to the non-gui boot list.
> Pushed "c" to go to a GRUB command line.
> Typed it the following:
>     root (hd1,9)
>     kernel /vmlinuz-2.6.10-5-386 root=/dev/hdb9 ro quiet splash
>     initrd /initrd.img-2.6.10-5-386
>     boot
> And viola!!  Everything booted fine.
> Of course, I already had edited my /etc/fstab and /boot/grub/menu.lst 
> files
> before-hand.
> Anyway, now that that is all said and done, any tips on how to 
> reinstall
> GRUB so that I don't have to boot off the CD and type that at each 
> boot?
> I tried running the following:
> [Note that I am now able to copy-paste because I can boot into my Hoary
> installation and use Evolution.  It'll be much easier now for me to 
> give all
> of you the output I get from commands (before I was typing it all up 
> manually)]
>> [me]@[foo]:~$ sudo grub-install --recheck --root-directory=/ /dev/hdb
>> Password:
>> Probing devices to guess BIOS drives. This may take a long time.
>> Due to a bug in xfs_freeze, the following command might produce a
>> segmentation
>> fault when //boot/grub is not in an XFS filesystem. This error is
>> harmless and
>> can be ignored.
>> xfs_freeze: specified file ["//boot/grub"] is not on an XFS filesystem
>> Installation finished. No error reported.
>> This is the contents of the device map //boot/grub/
>> Check if this is correct or not. If any of the lines is incorrect,
>> fix it and re-run the script `grub-install'.
>> (fd0)   /dev/fd0
>> (hd0)   /dev/hda
>> (hd1)   /dev/hdb
>> [me]@[foo]:~$
> Anyway, I rebooted and got the same Error 15.
> Any ideas on how to reinstall GRUB to the MBR or what I might be doing 
> wrong?
> ~Matt
> -- 
> ubuntu-users mailing list
> ubuntu-users at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 2939 bytes
Desc: not available
URL: <>

More information about the ubuntu-users mailing list