Hoary doesn't detect network card (Thinkpad T20)

Nathan Jones nathanj at optimo.com.au
Wed May 4 13:20:51 UTC 2005

Thanks Bryan and Jonathan for your suggestions. I am still lacking an
Ethernet interface, though...

Jonathan McLoughlin wrote:
>I believe you need the e1000 module, unsure why this isn't being
>detected and loaded, try 'modprobe e1000' and then
>/etc/init.d/networking restart

I tried this and also tried "modprobe e100", but still get no output
to "lsmod | grep eth". The modprobe command completed silently (no
output, no error).

Bryan Murdock wrote:
>had to pass to the kernel at bootup:
>acpi=off apm=on

I tried this from the grub boot menu and in /boot/grub/menu.lst. I
presume it is supposed to be appended to the kernal line. No luck. Aren't
acpi and apm power management terms?

Is /etc/modules.conf a place where I should see eth0? I get no match to
"grep eth modules.conf". 

It's a pity I don't properly understand how to work with modules, etc.
Maybe then I could figure it out. I'm fine as a GNU/Unix user, but rather
a newbie when it comes to administration. :-(

Perhaps I should try a clean install to make sure nothing from my Warty
setup is causing a problem. (But then, the LiveCD didn't detect the
network card either.)

Nathan Jones
[Thinkpad T20]

More information about the ubuntu-users mailing list