troubles with CD burning

grap pascal.gregis at
Sun Mar 13 23:06:51 UTC 2005

Hello everyone,

I have ecently installed an Ubuntu on my Dell laptop.
Until now I have been learning about the apt facilities and I am now testing 
if everything works well on the distribution.

My first problem (I hope I won't have any others) is related to CD burning.
This is the following :

When I boot my machine, I've got the following lines in /var/log/messages :

Mar 13 22:56:57 osborne kernel:     ide1: BM-DMA at 0xbfa8-0xbfaf, BIOS settings: hdc:DMA, hdd:pio
Mar 13 22:56:57 osborne kernel: hdc: SAMSUNG CDRW/DVD SN-324S, ATAPI CD/DVD-ROM drive

that means that my CDrom drive is recognized on /dev/hdc.

I have the followin in lsmod :

ide_cd                 38276  0 
cdrom                  35872  1 ide_cd

I can mount my cdrom :
$ grep cdrom /etc/fstab
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
$ mount /media/cdrom
$ umount /media/cdrom

but when I try cdrecord I have the following : 
$ cdrecord -scanbus
cdrecord: Warning: Running on Linux-
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
cdrecord: Warning: Linux-2.6.8 introduced incompatible interface changes.
cdrecord: Warning: SCSI transport does no longer work for suid root programs.
cdrecord: Warning: if cdrecord fails, try to run it from a root account.
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling

Even if I know that ide-scsi is deprecated for CD burning with kernel 2.6, I tried unloading ide-cd and cdrom, then loading scsi_mod, ide-scsi, cdrom, sr_mod but had no result too.
I even tried to put hdc=ide-scsi in the command line to start system (in grub: boot/grub/menu.lst), but nothing.

When loading ide-scsi, I also saw in my logs a line telling me to use cdrecord dev=/dev/... so I tried
$ cdrecord -dummy -v dev=/dev/hdc filetoburn
but had the same as the scanbus result.

I also tried to recompile cdrecord from sources, loaded and unloaded many times the modules, but no result.

I'm really getting out of ideas and find no better solution than asking for help, so could anyone give me a clue on this problem?

Thank you in advance


More information about the ubuntu-users mailing list