Wardriving Ubuntu & /etc/resolv.conf

Joe Potter jpotter1034 at cfl.rr.com
Sun Mar 13 19:48:04 UTC 2005

Hans Poppe wrote:
> Joe Potter wrote:


> I ran lasattr on resolv.conf and it had an "i".
> This is strange, I tried to edit the file in a root terminal and I could.
> However lsattr shows that after editing the "i" is gone and the changes to
> the file are there. I can set the "i" again, but if I can change it as root
> any program running in sudo mode could as well??
> Regards, Hans

Thanks for the test, I needed to know that. I run ext3 here with Ubuntu 
and the same with my main install of Debian.

I did find that chattr can work with reiserfs, but needs a lot of help. 
Not worth it.

If you run pump you can create a config and tell it not to overwrite. If 
you run dhcpd I think the info has already been posted here. I did 
edited the /etc/dhcp3/dhclient.conf file to get my name server running 
in Debian.

Thanks for the info, and good luck to you.

Regards, Joe

More information about the ubuntu-users mailing list