Wardriving Ubuntu & /etc/resolv.conf

Mark Stanton markstanton at ozonline.com.au
Sun Mar 13 14:43:19 UTC 2005

Hi guys,

thanks for the reply to my post but  it really dosen't seem to apply

----- Original Message ----- 
From: "Hans Poppe" <hans at poppe.nu>
To: <ubuntu-users at lists.ubuntu.com>
Sent: Monday, March 14, 2005 1:25 AM
Subject: Re: Wardriving Ubuntu & /etc/resolv.conf

> Joe Potter wrote:
>> Hans Poppe wrote:
>>> Joe Potter wrote:
>>>>Hans Poppe wrote:
>> <snip>
>>> Hi,
>>> I tried this and the output from lsattr /etc/resolv.conf reads
>>> "-------i------------" (didn't count the hashes :-), but it is still
>>> overwritten if I run dhclient. I suppose that means that when the lease
>>> is to be renewed my machine will run dhclient, and it will be 
>>> overwritten
>>> again. Haven't had the chance to try yet, but my neighbours unsecured
>>> WiFi lets me on the net, and it gives me a real IP for the NS, not an 
>>> NAT
>>> address. However this DHCP doesn'æt require a renewal for days, so I'll
>>> have to wait to see...
>>> Hans
>> If the "i" attribute is set as you show with the lsattr listing, then
>> even root is not suppose to be able to modify the file. You may not
>> change it or remove it.
>> Re-check that the "i" is still set, and then try to modify the file with
>> an editor. You should not be able to do so.
>> Or, try to remove it.
>> Let me know what happens.
>> Regards, Joe
> I ran lasattr on resolv.conf and it had an "i".
> This is strange, I tried to edit the file in a root terminal and I could.
> However lsattr shows that after editing the "i" is gone and the changes to
> the file are there. I can set the "i" again, but if I can change it as 
> root
> any program running in sudo mode could as well??
> Regards, Hans
> -- 
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> http://lists.ubuntu.com/mailman/listinfo/ubuntu-users

More information about the ubuntu-users mailing list