Hoary Hosed: synaptic in dependency hell

Kevin O'Gorman kogorman at gmail.com
Thu Jul 21 13:59:24 UTC 2005

On 7/21/05, Lee Braiden <lee_b at digitalunleashed.com> wrote:
> On Thursday 21 July 2005 01:27, Kevin O'Gorman wrote:
> > Results were poor.  Here's part of what I got.  Unfortunately, I don't know
> > what it takes to do the "configuration" that seems required.
> >
> > Setting up xfsprogs (2.6.20-1) ...
> > dpkg: dependency problems prevent configuration of ubuntu-base:
> >  ubuntu-base depends on at; however:
> >   Package at is not configured yet.
> > [snip]
> > dpkg: error processing ubuntu-base (--configure):
> >  dependency problems - leaving unconfigured
> Try running:
>   dpkg --configure -a
> --
> Lee Braiden
> http://www.DigitalUnleashed.com

Thank you Lee and Peter, these suggestions have led to improvement

1) I commented-out the tower repository
2) Purged the packages that indicated dependency on exim
     lsb (set my teeth on edge thinking this is Linux Standard Base
and I'm deleting
           this by remote login)
3) Restored with
     dpkg install mutt mailx lsb (great relief when this worked)
4) Tried several iterations and combinations
     dpkg --configure -a
     apt-get update
     apt-get dist-upgrade

And voila! no more error messages or further downloads.

There is the remark:
> The following packages have been kept back:
>   kdevelop3 kdevelop3-data kdevelop3-plugins

I have not been using Kdevelop, but would like to do so.  So, I'm
almost there, but
I have this one worry: how do I keep up-to-date with Java without tower-net?
The procedure I used does not prove that tower-net was the culprit, only that
somehow there was a non-ubuntu version of 3 packages for a time.

Any guidance?

Kevin O'Gorman, PhD

More information about the ubuntu-users mailing list