Serial Port Problems

Bob Nielsen nielsen at
Wed Jul 20 00:44:46 UTC 2005

On Tue, Jul 19, 2005 at 04:27:32PM -0400, David M. Carney wrote:
> I'm trying to use a Windows program with Wine that needs the serial port
> (/dev/ttyS0 or maybe /dev/ttyS1). The program interfaces with my ham
> radio and is used to do many things, such as set the operating
> frequency, etc.
> The program calls the ports Com 1, Com 2, etc. 
> I hate to admit it, but I have another drive with WinXP on it. I have
> also installed this program on the WinXP drive and it works perfectly.
> I have tried to set it up using Linux/Wine using the exact same setup
> parameters as my WinXP install but it won't work. The permissions
> on /dev/ttyS0 and /dev/ttyS1 are 660. Both, of course, are owned by root
> and the group is dialout. I am a member of this group and there are no
> modems in or attached to this computer.
> I tried (as a temporary experiment) opening up the permissions
> completely on these ports but they seem to change right back to 660.
> Any suggestions?

I haven't used wine recently, but never have been able to get the serial 
ports to work flawlessly when I have tried it.  You probably would have 
better luck with VMWare or Win4Lin.

You might take a look at some of the Linux ham radio programs, like 
xlog, gmfsk, tlf, etc., (see for a 
comprehensive list of available programs, most of which are available in 
universe or multiverse for Ubuntu).  These are not as flashy as some of 
the Windows stuff but generally work quite well (the serial interface is 
via the hamlib library, which supports a large number of radios).

Bob Nielsen, N7XY

More information about the ubuntu-users mailing list