Serial Port Problems

David M. Carney carney1979 at
Tue Jul 19 20:27:32 UTC 2005

I'm trying to use a Windows program with Wine that needs the serial port
(/dev/ttyS0 or maybe /dev/ttyS1). The program interfaces with my ham
radio and is used to do many things, such as set the operating
frequency, etc.

The program calls the ports Com 1, Com 2, etc. 

I hate to admit it, but I have another drive with WinXP on it. I have
also installed this program on the WinXP drive and it works perfectly.

I have tried to set it up using Linux/Wine using the exact same setup
parameters as my WinXP install but it won't work. The permissions
on /dev/ttyS0 and /dev/ttyS1 are 660. Both, of course, are owned by root
and the group is dialout. I am a member of this group and there are no
modems in or attached to this computer.

I tried (as a temporary experiment) opening up the permissions
completely on these ports but they seem to change right back to 660.

Any suggestions?


Registered Linux User #297958

More information about the ubuntu-users mailing list