Can't add a user, exists. Can't delete does not exist.

Scott Henson scotth at
Mon Jul 18 05:55:52 UTC 2005

Dave Walker wrote:

> Scott Henson wrote:
>> Dave Walker wrote:
>>> Ok I don't know how I got into this but something is broken.  A user 
>>> was having account problems so I was going to just re-create the 
>>> account.  I deleted the princ from Kerberos, and tried deluser 
>>> the_username.  I got:
>> What you need to do is 'getent passwd'
>> That command will tell you what the system sees as far as users go.  
>> If you see your user in there, something other than /etc/passwd is 
>> providing that user.  You can check what is providing that user by 
>> /etc/nsswitch.conf.   Check the passwd line.  For a normal system it 
>> will have compat and files.  If anything else is on that line then 
>> youll have to remove the user from there.  If your using kerberos, 
>> you might see ldap on there.   Other than that, I'm not sure why you 
>> would be getting that error.
> It does show the users in there... however my nsswitch.conf:
> passwd: files
> So, I got nothin.
Wow, thats odd.  I don't know of anything else that can affect nss.  I 
work with nss on a regular basis and Ive never seen this.  Have you 
tried a reboot?  Maybe libc is confused about your fs view?  I don't 
know.  I'm stumped, sorry.

More information about the ubuntu-users mailing list