loop-AES and ubuntu

Nik4 ulist at gs1.ubuntuforums.org
Thu Jul 7 14:08:23 UTC 2005

Lee Braiden Wrote: 
> On Thursday 07 Jul 2005 10:51, Nik4 wrote:

> > On knoppix i use the the follow to mount the encrypted partition

> > (hda7):

> > losetup -e aes /dev/loop1 /dev/hda7

> > mount -t reiserfs /dev/loop1 cryptoloop

> >

> > On Ubuntu I use the same two statements above but the mount
> statement

> > generates an error (bad superblock etc). I can still use Knoppix on

> > that partition, so looks like the problem is with the losetup

> > statement.


> >Where are you getting encryption keys from?  


> Once I enter:

> >> losetup -e aes /dev/loop1 /dev/hda7

> it prompts me to enter the password. After that I execute the 2nd
> statement to mount the loopback device:

> >> mount -t reiserfs /dev/loop1 cryptoloop


> This system has been working for quite some time on Knoppix. Even now
> it works via Knoppix. Of course,  if i enter an incorrect password - i
> get the same error. The issue seems to be that there is some difference
> between the two losetups. I have also tried the -N option with no
> success (losetup -N -e aes ....).


More information about the ubuntu-users mailing list