[Breezy] X won't start, following today's update ?

Stephen R Laniel steve at laniels.org
Mon Jul 4 14:39:56 UTC 2005


On Mon, Jul 04, 2005 at 04:32:24PM +0200, Vincent Trouilliez wrote:
> Installed Colony #2 the other day, worked fine. 10 minutes ago I do my
> daily "dist-upgrade" and see loads of stuff related to X. 
> I update and then X refuses to start, stating that "etc/X11/X is not
> executable"... does anyone get the same, or is it just me ?

No, I definitely got that as well. The installation actually
didn't complete for me, which is good -- I get the sense
that had it completed, I wouldn't be able to run X at all.

They definitely broke a symlink: if you look at
/usr/bin/X11, you get

lrwxrwxrwx  1 root root 8 2005-07-04 00:12 /usr/bin/X11 -> /usr/bin

So that's bad. I'm not sure why, but I'm running X just fine
even with that broken symlink.

More serious was that the /usr/X11R6/bin/X symlink was
broken. When I manually relinked it to Xorg-debug (in the
same directory) everything worked fine.

But now I'm not going to do any upgrades to my X packages
until all this stuff gets fixed.

-- 
Stephen R. Laniel
steve at laniels.org
+(617) 308-5571
http://laniels.org/
PGP key: http://laniels.org/slaniel.key
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20050704/b8f42473/attachment.pgp>


More information about the ubuntu-users mailing list