Problem enabling sound in Ubuntu

Bob Nielsen nielsen at
Sun Jul 3 01:48:33 UTC 2005

On Sat, Jul 02, 2005 at 12:19:51PM -0700, Mike S wrote:
> Ravi Kumar wrote:
> >Hello,
> >      I recently ditched Fedora core 2  and installed Ubuntu. But I
> >have run into sound issues. My sound was working properly - using ALSA
> >module in Fedora Core 2 . Now it is not working at all. At the best I
> >get some weird sound when I play a mp3 file.
> >
> >I had posted  how I succesfully configured my sound card to work
> >properly in Fedora here :
> >
> >
> >
> >But when I used the (more or less) steps, I could'nt get the same
> >sound card working in Ubuntu. I am new to debian based linux distros.
> >
> >So please someone kindly help.
> >
> >Thanks a lot in advance
> >Ravi
> >--
> >
> >
> > 
> >
> Are you using the ubuntu kernel, or a self compiled kernel?  This is a 
> problem I ran into last night, sound worked fine in the ubuntu kernel, 
> ALSA and OSS, but building my own 2.6.12 kernel yeilded no sound.
> I am still investigating my own problem, and have also posted the 
> question here.  Don't know if it will help, but for the time being can 
> you use ESD?
> I know it's a daemon, but ESD has worked for me when all else fails.  I 
> am also using ubuntu PPC so I'm betting the platforms vary, and may make 
> it even less likely that there is a relation to our problem.
> --Mike S

After install a self-compiled 2.6.12 kernel and rebooting, I only had 
sound in certain instances, like after logging into gdm.  I then noticed 
that /dev/dsp did not exist (thanks, udev!).  I tried a bunch of things 
and finally it appeared, unfortunately I'm not sure what exactly did the 
trick so I expect that I'll have to go through the process again the 
next time I reboot.  :-(


More information about the ubuntu-users mailing list