A number of problemsu

Matt Zimmerman mdz at canonical.com
Tue Sep 28 05:12:15 UTC 2004

On Mon, Sep 27, 2004 at 08:56:44PM -0400, Ben Novack wrote:

> 1) I've got an AC97 internal sound chip, and it only plays through the
> laptop's built-in speakers. The headphone jack's silent.

Haven't heard that one before.  Have you tried adjusting the various levels
in the mixer applet?

> 2) I've got a USB flash drive (A Lexar JumpDrive), plus an 80-gig
> external drive (Maxtor). Both are FAT32 formatted. Both have been
> recognized without a problem by 2.4-kernel distros. Once, for no
> discernable reason, Ubuntu found the flash drive and put it on my
> desktop, but five or six other attempts lead to failure. I pop in the
> drive and nothing happens. My USB mouse works without a hitch.

File a bug with the output of the "lshal" command with the devices plugged

> 3) My 802.11b wireless card seems to have been detected, since I got a
> handy connection-strength meter applet. However, I can't actually
> connect! I used the Networking program to create a new Wireless
> connection, but when I tried to enable it, the Networking program sat
> frozen for a few minutes, then unchecked the Enabled box. This
> happened even in the presence of an unsecured wifi network. Also, to
> get at the network I'll be using most often, I need to be able to
> specify an SSID (it's not broadcast) and a 128-bit WEP in the form of
> a hex sequence. Where do I do that?

The "network name" is used for the ESSID
(https://bugzilla.ubuntu.com/show_bug.cgi?id=1295).  Currently, there
doesn't seem to be a place to configure the WEP key in the GUI configurator.
Enough people have asked about it that I think it deserves a bug report as

> 4) Worst of all, my wired connection doesn't work. Annoyingly, my
> university's dorms are set up to use 802.1x authentication, which means
> that until I'm authenticated, DHCP clients and the like won't see anything
> at all out there. I need to get xsupplicant installed and set up. I
> grabbed the source and moved it into the ubuntu machine during the one
> time that my usb drive was recognized. I ran sudo ./configure in the
> expanded directory. It foudn two missing prereqs: gcc and openssl. (I have
> to confess to being open-mouthed amazed that there was no C compiler at
> all in the default installation). I popped over to Synaptic and found both
> available on the CD. I installed them, and the configure happily finds
> gcc... but insists that OpenSSL isn't installed!

xsupplicant sounds like the kind of thing that we should have on the CD,
packaged and ready to go.  It seems to have been added to Debian recently;
I'll see if it's suitable for a late inclusion in Warty.  Meanwhile, here's
a package built for Warty:


If you can find a way to get that onto your system, it should get you going.
Install it with "sudo dpkg --install xsupplicant_1.0-1_i386.deb"

In the case of OpenSSL, it's looking for the development library, while you
probably only installed the command-line tools.  We don't ship development
libraries on the CD (there isn't nearly enough space), though we do include
the compiler and associated tools.

 - mdz

More information about the ubuntu-users mailing list