A number of problemsu

Ben Novack bennovack at gmail.com
Tue Sep 28 00:56:44 UTC 2004

Well, I decided to introduce my laptop to Ubuntu and finally start
learning Linux. I love what works and hate what doesn't.

The laptop's a Dell Latitude D600 - Pentium M Centrino. It's nearly
identical to the Inspiron 600m.

In increasing order of severity:

1) I've got an AC97 internal sound chip, and it only plays through the
laptop's built-in speakers. The headphone jack's silent.

2) I've got a USB flash drive (A Lexar JumpDrive), plus an 80-gig
external drive (Maxtor). Both are FAT32 formatted. Both have been
recognized without a problem by 2.4-kernel distros. Once, for no
discernable reason, Ubuntu found the flash drive and put it on my
desktop, but five or six other attempts lead to failure. I pop in the
drive and nothing happens. My USB mouse works without a hitch.

3) My 802.11b wireless card seems to have been detected, since I got a
handy connection-strength meter applet. However, I can't actually
connect! I used the Networking program to create a new Wireless
connection, but when I tried to enable it, the Networking program sat
frozen for a few minutes, then unchecked the Enabled box. This
happened even in the presence of an unsecured wifi network. Also, to
get at the network I'll be using most often, I need to be able to
specify an SSID (it's not broadcast) and a 128-bit WEP in the form of
a hex sequence. Where do I do that?

4) Worst of all, my wired connection doesn't work. Annoyingly, my
university's dorms are set up to use 802.1x authentication, which
means that until I'm authenticated, DHCP clients and the like won't
see anything at all out there. I need to get xsupplicant installed and
set up. I grabbed the source and moved it into the ubuntu machine
during the one time that my usb drive was recognized. I ran sudo
./configure in the expanded directory. It foudn two missing prereqs:
gcc and openssl. (I have to confess to being open-mouthed amazed that
there was no C compiler at all in the default installation). I popped
over to Synaptic and found both available on the CD. I installed them,
and the configure happily finds gcc... but insists that OpenSSL isn't

I should note that some strange-looking errors come up during bootup.
I'd post them, but A) I'm not sure where the boot log is located, and
B) even if I knew, I don't have wired or wireless network access, and
I can't even drop a text file onto my usb key and upload it from

Any assistance any of you folks can offer would be much appreciated. I
really want to like Ubuntu, but not having *any* network access, or
even being able to get files on and off the system, is trying my


More information about the ubuntu-users mailing list