Install report

Stuart Bishop stuart at stuartbishop.net
Thu Sep 23 04:53:08 UTC 2004


The tool is a brand spanking new DELL 8600 (Centrino machine) with the 
fuck-you 1900x1600 15" display.

The other tool is me. I'm now a developer, but have done sys-admin and 
dba for over ten years with the bulk of my Unix work on Solaris. The 
last linux box I administered was Redhat 7.2 (which I didn't install). 
The last linux box I installed myself was a Slackware (4? sometime in 
the 90's). I gave up on using Linux on my desktop, as it was just too 
much a pain to configure and run, instead using Windows and a terminal 
window running screen on a remote unix box most of the time. I then 
switched to OSX and have been on it for the last 2-3 years. I got bored 
with tweaking my desktop sometime in the last millenium and want a 
system that works and has sane defaults in the UI.

- Default is to erase my entire hard drive? Eek! I hope there is a 
confirmation on the next page (and I'm not tempting fate to find out)!

- No way to shrink the existing NTFS partition on the install CD. 
Downloaded the Gentoo based System Rescue CD 
(http://www.sysresccd.org/), containing QTParted which looks cool and 
worked well. Something like this needs to be integrated into our 
installer for Hoary. We might want to document using sysresccd.org as a 
workaround until this is done?

- Most linux newbies, as they have a windows partition to worry about, 
will have to do a manual partition. A third option (Use all free space) 
would be nice. The partition editor says use one big file system + 
swap, but neglects to mention how much swap linux wants or needs. I've 
gone for what the partition editor recommended after I told it to use 
the rest of the disk space - hopefully this was done based on how much 
RAM I have installed.

- Australian timezone defaults to Sydney. Bastards.

- 2 second timeout on grub seems way too fast. I'd go for 5 or 6 with a 
more informative message, or people might think Ubuntu nuked their 
Windows.

- Seems to have booted into the correct resolution. Man that font is 
tiny on a 1900x1600 15" LCD display - couldn't we increase the default 
font size for high resolutions? At least for the login box lost in the 
middle of the display?

- No wireless. The card is detected, but nobody wants to know what my 
WEP password is so it is not surprising it cannot connect. I've managed 
to get it connected by manually entering some iwconfig comands and 
rerunning the GUI, but I have no idea if it will stick after the next 
reboot. Hmm.. adding the relevant line to /etc/network/interfaces does 
the job, but the Gnome config applet nukes this if I run it. So I won't 
run it for now.

- Trying to configure the wireless the first time crashed 
'network-admin', but no idea what product to send the bug report too. 
Discussions I had with Martin Pitt at the conference tell me we can fix 
this for Hoary (the bug reporting - not network-admin).

- Setting up a tethered connection using the GUI tool worked, although 
my nameserver was not picked up from DHCP. I needed to manually enter 
the IP address in the DNS panel.

- Sound works.

- My - what a lot of screen savers. At least the best one is there 
(blank screen) :-)

- The buttons on my keyboard that DELL tells me controls volume don't. 
No idea if there is a standard for these sorts of 'multimedia keys' 
that we can support. Brightness control buttons (Fn-up and Fn-Down) do 
work. Other Fn-magic keys don't (eject CD etc.)

- Hitting the power button appears to want to shut down the system but 
fails (hangs after outputting acpi_power_off. Holding down the power 
button completes process)

- Suspend key does nothing

- Closing the lid and opening it shows the screen saver has kicked in, 
or sometimes shows nothing but a flashing cursor that requires a power 
cycle

- There is no firewall GUI. Looks like we have no filters configured by 
default, which scares more advanced Windows or OSX users. I shouldn't 
have to port scan my own machine to determine what is open and what is 
not.

- Synaptic seems cool. I wouldn't have had a clue what the various 
optional repositories were though if I hadn't picked it up through 
osmosis on IRC and at the conference (well - I still don't know why we 
have warty and warty-security. It can't be crypto as gpg is already 
installed from the cd). Selected the deb universe and dev 
warty-security repositories. Maybe I should read that documentation... 
nah...

- My.... what a lot of packages... but no Sun JDK (I assume Sun is 
still being a pain about click-through licences?) which was the second 
thing I
wanted.

- Installed Thunderbird (never tried Evolution, and can't be  bothered 
at the moment).

- Gaim notification sound defaulted to 'system beep' which was most 
annoying. Setting it to 'ESD' works, and rent-a-cat agrees.

- Trying to add a timeserver using the 'Time and Date Settings' control 
panel gives me the error message:
	'NTP support is not running. Please run NTP support in the system to 
enable synchronization of your local time server with internet time 
servers'.
  I have no idea what 'run NTP support in the system' means, even though 
it parses as English.

- My time in Windows is correct. My time in Ubuntu is 10 hours out. I 
assume this means one OS is running with the system clock in localtime, 
and the other with the system clock in UTC. *update* appears to be 
fixed after package upgrades.

- If there is no network when login in, the gaim error dialog is hidden 
behind the ubuntu startup splash, which doesn't go away because gaim 
isn't finished...

- Hey - X no longer sucks. Fonts are nice and smooth, and there are 
more than 2 of them! And I didn't have to spend 3 days screwing around 
with
{fv,ct,t,}wm!

- Clicking on the 'Desktop' button in Synaptic's package manager gives 
a 'Folder unreadable: No such file or directory' error. I guess its 
concept  of Desktop is different to Ubuntu's.

- Thunderbird's IMAP support pales in comparison with Apple's default 
Mail.app. Having to wait a second or two after clicking on an email for 
it to be download makes email gardening sooo slooow, and delivering in 
the foreground - urgh. Need to find a more proactive email client :-( 
Maybe that Evolution thingy, although it doesn't seem to want to let me 
move my mail folders out from under my INBOX (need to set what 
Thunderbird calls the 'IMAP server directory, but couldn't find it 
yet). Maybe it is better in Thunderbird 0.8.

- Did a big package upgrade

- Firefox '0.99+1.0PR-0ubunto' has a broken about dialog (just get a 
gecko error).

All up, at first I was thinking 'oops - should have bought the Mac 
instead' but I'm coming around now :-) I'm sure there  is gobs of cool 
stuff for me to be playing with in the packages - I need some sort of 
'recommended in Universe' list so I only have to test one or two mp3 
players rather than 10 (I guess this would have to be more editorial 
than official, since it is based on opinions. I guess that 'popularity 
contest' package I saw might help here too). Or maybe ubuntu + 
restricted
serves this purpose?

--  
Stuart Bishop <stuart at stuartbishop.net>
http://www.stuartbishop.net/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20040923/090bf3b7/attachment.pgp>


More information about the ubuntu-users mailing list