Wireless issues...

John dingo at coco2.arach.net.au
Sun Sep 19 00:37:13 UTC 2004

Chris Edwards wrote:

>* John Hornbeck (hornbeck at freeshell.org) wrote:
>>I am trying to get my ipw2200 card to work.  I notice that on bootup it
>>finds the card and loads the module.  It throws a irq error though.  I
>>have rebuilt the kernel now and installed the ipw2200 drivers from
>>ipw2200.sourceforge.net and I still get no wireless interface.  I can
>>get this to work in normal debian.  Anyone else having problems with
>>this card.
>I had the same problem with my ipw2100. The solution was to disable the
>parallel port in the BIOS. It was trying to use the same IRQ. I suspect
>it's an ACPI of APIC issue, and one of the kernel commandline options
>might fix it. You're not using a Dell by any chance are you?
There should be a BIOS menu where you can specify IRQs to be reserved 
for ISA devices. Do so for the printer IRQ(s).

It's designed to avoid conflicts such as this.

You might also check your setting for PnP OS. I've been specifying that 
Linux is PnP since the advent of 2.4 kernels and it's always worked for me.

I suggest which ever way you have it set, change it _before_ fiddling 
with the IRQ settings I mentioned.

More information about the ubuntu-users mailing list