scanner only as root

Soren Hauberg soren at
Wed Nov 24 22:31:44 UTC 2004

Thanks for the quick reply

Sebastian Müsch wrote:
> Hi,
> I think, you'll have to change the Access-rights of the device-node, so the
> scanning-User has Read/Write-Access.
> To do this:
> 1. Create a group called scanner (or a group you'll like)
The group scanner allready existed
> 2. Add the users you want allow to scan to this group
I added my account to this group using gnome-system-tools
> 3. Add a code sniplet to an init-script to chown and chmod the device on
> boot, so the users of the group "scanner" can RW on it.
Before I start to create init scripts (this is ubuntu not gentoo :-) ) I 
have tried the following:
   sudo chmod +rw /dev/lp0
   sudo chown sh.scanner /dev/lp0    (my username is sh)
but xsane still doesn't find my scanner when I'm not root.

> (The device may be /dev/sgx ... where x is a number, the first scanner gets
> 0, the second 1 ... If you are unsure sane tells you the device it's using
> ;-) )
In the above I assumed that /dev/lp0 is the parport. sane only tells me 
that it uses parport0, but there is no /dev/parport0

> cu
> Sebastian

> Soren Hauberg wrote:
>>I just managed to get my old parport scanner to work with sane. The
>>problem is that it only works as root, so I have to give a password and
>>accept a warning from xsane before I can scan.
>>Is there a way to get around this?
>>By the way, the scanner is a Canon FB330P

More information about the ubuntu-users mailing list