Found slave hard drive, but can't open folders or files

use_real_email at use_real_email at
Wed Nov 17 04:26:23 UTC 2004

-mkdir /ddrive

mount -t vfat /dev/hdb1 /ddrive

So, now it sees it. However, I can't open files or

folders. I even tried to open a txt file with the

OpenOffice text editor, but still no go.-

You made the folder in the root partition, which means it's more than
likely locked read only to anyone but root. Try this instead:

sudo umount /ddrive (unmount it)

mount (make sure it's actually unmounted - /dev/hdb1 should not be in

mkdir /mnt/ddrive (put a folder where it belongs)

chmod -R 644 /mnt/ddrive (set permissions to give yourself r/w access)

sudo mount -t vfat /dev/hdb1 /mnt/ddrive (remount it)

mount (read this and make sure /mnt/ddrive  is on same line with

sudo rmdir /ddrive (if it's ok, now clean up after yourself)

Then it should work r/w for you in /mnt/ddrive

Now you can:

man mount

and learn about your mounting options!


More information about the ubuntu-users mailing list