Java plugin stops working, perhaps due to Garrett's kernel?

janne jan.moren at
Wed Nov 17 01:59:28 UTC 2004

Some while ago, I installed Java and the Java plugin. I didn't bother
with the package management stuff, since it gets installed in its own
private directory (and so doesn't conflict with anything), and I only
use it for one web plugin and nothing else. So I downloaded the 1.5jdk
(for some strange reason that plugin never worked with just the runtime
environment), and followed instructions.

It worked.  

Now, a couple of weeks later, suddenly the plugin does not work anymore.
Java itself works - I can run demo apps in the install. The plugin shows
itself to be registered with Firefox. But when I try to go to a page
with a java plugin - any such page, not just the one I need - Firefox
just freezes, or crashes, depending. Checking running processes shows
that the java vm is never started.

Now, I have not changed the version of Firefox (still the same ubuntu
ships with). I have not touched the java install directory or the plugin
link - and according to timestamps, nothing else has done so either.

What has changed is that I now run Matthew Garrett's 2.6.9 kernel, to
get suspend to work. Could that possibly be a source of this problem?

Any ideas, anybody?

Trust the Computer. The Computer is your friend.
Tel. (Japan) 090-3622 8920            Dr. Jan Morén (mr)
                                      Dept. of Cognitive Science    Lund, Sweden

More information about the ubuntu-users mailing list