USB instabilities.

Matt Zimmerman mdz at
Fri Nov 12 08:57:14 UTC 2004

On Tue, Nov 09, 2004 at 03:50:16PM -0800, George Farris wrote:

> I have noticed that the USB subsystem seems somewhat unstable or buggy
> in Warty and or kernel 2.6.8 and or hal etc.  Here is what I am seeing.
> Snapscan USB scanner.
> ---------------------
> If I run xsane as root everything is fine.  I can even get the xsane to
> work as a normal user, however, another user has problems.  If I reboot
> or logout and back in, boom the scanner is no longer found.  I can run
> xsane as root but no matter what I do I can't run it as a normal user.
> This scenario goes around in circles until I get tired and give up.

It might have saved you some frustration to search the bug tracking system:

This bug isn't solved yet, but it is known.

> Two USB printers.
> -----------------
> Warty will not see the second USB printer consistently sometimes it
> does, sometimes it doesn't, reboot and the whole ball game is a new
> one. 
> USB printer and USB scanner plugged into the same remote hub.
> -------------------------------------------------------------
> Printing will not work as long as the scanner is plugged in to the hub.
> If I remove the scanner and plug it into a usb port on the back of the
> computer, things start to work.  Through out all this the Device manager
> show everything fine.

Problems recognizing USB devices are often indicative of more general IRQ
problems.  Try booting with noapic, pci=noacpi, nolapic, acpi=off (each on
its own) and see if one of them improves the situation.  File a bug with the
results, including the output from "dmesg" in each scenario that you test.

 - mdz

More information about the ubuntu-users mailing list