[ubuntu-uk] Toshiba Portege P4010 - BIOS Bad Block 3

David Goldsbrough daveg at boavon.plus.com
Mon Oct 17 16:44:36 UTC 2011


Up until Friday I was happily runnng Ubuntu on subject machine.  It
has never managed to do a restore before, and I have always shutdown
and re-booted whenever softaware updates requested it.

I have never tried ever to suspend it or hibernate it, due to bad
attitude on my part as I regard this function as "fancy-dan stuff".  I
also suspected it would never be able to cope on the basis that if
"restart" never worked then suspend or hibernate never would either.

On Friday though my "wisdom" got the better of me and I tried to
suspend it.  Boy, did it sulk.  It just went dead!  Any attempts to
re-boot it results in an error message "BIOS(Block3) is damaged! (call
user serviceman.)  Serviceman: Place maintenance disk in drive and
press any key when ready."

I have spent the weekend on and off researching the net and trying a
few things.  It would seem that I am unable to access the BIOS at boot
time.  Pressing F2 is the normal access method but I have tried the
ESC key and the left-shift key.  The DVD drive is not accessible and
there is no floppy drive.  I do have a usb read-only floppy drive
available but I suspect the usb ports are not operable either.

I did see some reference to getting a boot floppy and altering some of
the bytes with a hex editor which somehow fooled the BIOS and then
allowed the BIOS to be flashed.  I never pursued this solution as I
could not think (or did not have the means) of achieving.  I also had
some doubt whether it would work.  I could find nobody who had
actually really fully solved the BIOS error.

The machine cost me less than £50 some years ago, but I loved it so
much!  It was my Ubuntu/linux learning platform.  Is it time for the
scrap heap?


More information about the ubuntu-uk mailing list