[ubuntu-uk] Disk Rescue!

Matthew Daubney matt at daubers.co.uk
Mon Aug 30 20:55:28 BST 2010

On Mon, 2010-08-30 at 20:24 +0100, daveg at boavon.plus.com wrote:
> Many thanks for the various pieces of advice.
> Have just finished booting up an old WIN98 setup CD, using the F8 key
> managed to get to a shell prompt where it had loaded a few utils into a
> RAMDISK.  FDISK /STATUS showed some partitions.  Deleteing them appeared
> to work, but then when trying to write a new partition it just hung again.
>  Re-booted and tried again. Similarly the status still showed the
> partitions being there - even though I thought I had deleted them. 
> Realised, they were just marked for deletion and cos the new partition
> hadn't worked they were still there.  This time I deleted and then exited
> from FDISK only to receive a disk write error.

Your disk is dead. Time for a new one.

> All similar symptoms to other methods used so far.
> Conclusion:-  Either the disk is well and truly busted OR for reasons I
> cannot explain or fix is that the MBR is opened read-only and it is busted
> also.

This would not give you write errors when you try and write a filesystem
to disk. If you can boot a live CD, don't try and install to the HDD,
just see if you can partition the disk with gparted. If you get more
write errors in dmesg or the system log, new disk time.

> Is'nt there some form of low-level utility which would merely zap the disk
> with zeros or something regardless whether it has some form of protection
> on it?  I don't need the data and I don't need any software - I can
> install o/s afterwards.

> Lessons for others to learn: - if you haven't backed up your MDR and/or
> taken an image of your disk and it is important to you - do it regularly
> before it is too late.

Lesson is always, always, always backup!

-Matt Daubney

More information about the ubuntu-uk mailing list