[ubuntu-uk] Disk Rescue!

Tony Pursell ajp at princeswalk.fsnet.co.uk
Mon Aug 30 17:57:43 BST 2010

On Mon, 2010-08-30 at 16:21 +0100, daveg at boavon.plus.com wrote:
> I'll try to be sucinct as possible, but also explain as fully as I can.
> Booting up, I get the grub menu.  Choosing any of the 4ish(?) Ubuntu
> choices (exept restore versions) results in hung system. Choosing XP
> results in hung system.  Choosing one of the restore options results in a
> scrolling screen of text, so fast it is difficult to pause and read but I
> do recall some bad messages relating to DMA.  I can get to grub prompt but
> I haven't much of a clue from here whether this is a good thing or not.
> Portege does not have floppy drive - just DVD.  However, I did try
> re-installing XP but it hangs when it comes to trying doing anything with
> the hard drive.  Tried a number of live CDs again in an attempt to use
> partitioning software to sort it all out, but to no avail.  Even
> attempting to delete partitions - it just hangs.  Latest attempt was using
> a live version of Gparted but again although it can see my partitions any
> attempt to change them causes problems - its as if they are write
> protected; but no feedback from tools says this.
> I'm investigating whether I can repair the MBR - if in fact that is wrong.
>  Thought I'd found some utility to do this but it doesn't appear to be
> part of any distro I have.
> All very frustrating.  As I say - any tips would be appreciated.

This doesn't sound good. I'm no expert, but I can suggest a couple of

Have you tried F8 when you are booting XP.  This gives you some trouble
shooting options.

In Gparted, if disks are 'busy', the Delete and Resize/Move buttons are
greyed out when you click on the partition.  If Gparted is showing the
partitions then the disk cannot be completely dead as it can still read
the partition table.


> Message: 5
> Date: Sun, 29 Aug 2010 15:11:53 -0700
> From: Traveller
> On 29/08/2010 12:20, daveg wrote:
> > I have spent best part of today trying to rescue my 20GB hard disk from my
> > beloved Toshiba Portege running Ubuntu 10.4 and XP on a partition that is
> > hardly used.
> >
> > Last updates must have screwed my MBR (I'm guessing but may be wrong about
> > the updates - but do reckon the MBR is no longer any good)
> >
> > I've messed about with various partitioners, run up a few live distros
> > including runnig cfdisk -z from a live cd but all to no avail.  I dont
> > care about any data - I'll be happy with a fresh install.  I'm beginning
> > to think my IDE conroller has gone.  Thought those were on disks though -
> > not boards - but this is an old machine - circa 2002/3. Did try attaching
> > it into an even older Toshiba - but same problems.  Don't have any spare
> > disks to try on the Portege.
> >
> > Just downloading a live version of Gparted but I dont think this will help
> > somhow - but fingers crossed.
> >
> > Anyone got any tips?
> >
> >
> Not sure I understand what the problem is! Are you able to access the
> disk at all? Do you get warnings, etc. when you try to boot? Do you have
> an OS that can be booted from the disk? Not long ago, I munged up a dual
> boot, and to get WinXP back, I had to use my rescue Disk, open a command
> prompt and run "fixmbr", which killed grub, but gave me back my XP.
> Perhaps you need to do something similar?
>                 Dave
> End of ubuntu-uk Digest, Vol 64, Issue 74
> *****************************************

More information about the ubuntu-uk mailing list