[ubuntu-uk] Vim keybinding for filter

DarkOtter hello at darkotter.com
Sun Aug 17 19:40:49 BST 2008

Sorry to ask what is probably a silly question (I bet i've just missed one vital
detail in this). Anyways, I am trying to set a keybinding for a filter in vim. I
can use the filter normally (i.e by typing :%!~/Scripts/Signature <enter>) but
when I try to map it to a key it does not worked. The command I tried using to
map it was as follows:

:map ^s :%!~/Scripts/Signature

this does not give me an error message, but then when I press ^s nothing
happens. I couldn't quite remember whether ^s was alt+s or ctrl+s in vim, so I
tried both and neither seemed to do anything.

Thanks in advance for any help.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20080817/ae3159f4/attachment.pgp 

More information about the ubuntu-uk mailing list