[ubuntu-uk] Vodafone 3G card with T-Mobile uk SIM [Works]

alan c aeclist at candt.waitrose.com
Sat Jun 30 17:58:04 BST 2007

I am delighted to find that (with Kubuntu 7.04) a Vodafone 3G card
(pcmcia) with T-Mobile SIM (payg) works easily in my Dell Inspiron
1100. (Note 7)
Delighted is an understatement.

I bought the (unlocked) 3g card from ebay (40 uk pounds).
The T-Mobile pay as you go SIM was a nominal 50 Pence from T-Mobile.
(note 4)

The SIM arrived with a topup card which I used to put 10 pounds credit
on at a shop checkout till.
The 3g card was a checked ok or repaired returns item, in a
vodafone pack (note 1) with documents and CD of Vodafone Mobile
Connect  (windows) software (which I used initially to check it all
worked)(note 5)

I ensured kubuntu 7.04 was fully updated, inserted the 3g card,

I checked (before and after card insertion) terminal:
  ls /dev/ttyUSB*
and saw
/dev/ttyUSB0  /dev/ttyUSB1  /dev/ttyUSB2
were from the card. (I understand that the first is used for data  the
next is not used, the last is used for monitoring).

Then I configured kppp (note 2)
Start KPPP and press 'Configure...'.
Under 'Accounts', press 'New' and [manually] create a name for the
3G/GPRS connection
[I used fusion3g as a name].
Enter [add] the telephone number to dial as *99***1# (dial first
profile on data card).
Press 'Customize PPPD Arguments' and enter [add] the argument novj
(THIS IS IMPORTANT or the link will not start!).

Modem 'Device' tab:
Under 'Modems', add a new modem. [I used fusion as a name].
 From the modem device drop-down menu I chose /dev/ttyUSB0 which I knew
existed  [after checking as noted above]
and connection speed I set to 460800

Modem 'Modem' tab:
Under the modem's 'Modem' [effectively the properties] tab, press
'Modem Commands',
and in 'Init String 2' you need to enter:
note that it is .uk not .co.uk.
If you're using a provider other than T-Mobile UK then you'll need to
change this to reflect the correct APN (access point node)
for your provider (see 'GPRS in the UK' link in note3).

KPPP Login Username and password don't seem to matter, but martin (and
I) set them
to web/web.

I use the laptop on a wired LAN mostly. So the
SystemSettings>NetworkSettings showed eth0 is usually enabled.
I had used the 3g card with windows to test it out, so I knew where in
the house a reasonable signal could be found and used this
location.(note 6)

I disabled the eth0 (using admin button)
then connected using kppp. It connected ok and firefox worked. If eth0
was not disabled, kpp still made a connection, but browser could not get
internet or maybe dns, anyway, it did not work.

Note - The T-mobile (UK) payg [web 'n walk] is not intended for PC use
really, more for mobile phone use. This package allows a day's use for
a capped amount of one pound per 'day' only. But beware, full prices
apply if the midnight boundary is crossed online (GMT??), the fair use
is stated as 40MB only, I think, which is fine for me when I am out
and about.

I heard that Orange also have a similar payg sim and web availablity,
but have not checked.

Roaming is not included the one pound package.

Note 1:
ebay 'UNLOCKED 3G/UMTS Vodafone GPRS/3G QUAD BAND Data Card'

According to the excellent site http://www.pharscape.org/  (also has
forum)   the QL prefix to my card serial number indicates a certain type -
GlobeTrotter 3G which is the same as GlobeTrotter Fusion but without wifi.

Note 2:
Another key site was
'Using T-Mobile UK's 3G Datacard Under Linux'
(Martin's pages)
This site provided the APN for t-mobile for me to use initially in
windows which was a nightmare to get working (note 5).
In this post I heavily use information directly from the site. Many
thanks for the information. (I did not use the symlink approach)

Note 3:
The site in Note 2 above includes a link for 'GPRS in the UK'

Note 4:
T-Mobile payg SIM only:
(see Quick guide to costs)

Note 5:
I initially installed the windows software to test things, but
although the sim received texts instantly (top up successful)  it
refused to connect to internet. Errors mentioned ports. I uninstalled
the existing wireless card software and did a lot with everything I
could think of, (lots of google too)  still errors, mostly ports.
Google was depressing - others had similar problems and I could guess
that this was a  reason why the item was returned to a no fault found
report! I found some later-than-my-version-5 software and downloaded
it from vodafone. The install needed windows SP2. So I installed 
It was a small windows partition so space became near critical (it
took a GB!) More uninstalls and clearance for space. A lot of time taken.
The new vodafone software then installed ok.

Unfortunately the configuration offered included about every supplier
in the world by not T-Mobile! So I reinstalled the original version
:-)  and now got a more sensible error about APN, which I solved using
Martin's Pages for Linux! Thank you Martin!

Continuing, I changed the HD (laptop caddy) and tried the CD install
again. This time no ports problems, and I had fore knowledge of the
correct APN details, it worked ok. So my previous 10 hours of work and
endless re booting was not needed on the second 'machine'. I do not
need reminding why I do not want to use windows.

Note 6:
The procedure described here for kubuntu does not result in visibility
of signal strength or data downloaded, other software may be
available(?)  - I think (see site in note 1, COMGT?)

Note 7:
It was NOT necessary to do *any* install, or compiling, the kernel
already obviously supports the driver, and no edit of any /etc
configuration files either, despite the large amount of detail
available on sites mentioned here and others about editing and
compiling things.

happy surfing!
alan cocks
Kubuntu user#10391

More information about the ubuntu-uk mailing list